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    Safety Guidelines 
This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring to property damage only have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

   
Danger 

indicates that death or severe personal injury will result if proper precautions are not taken. 

   
Warning 

indicates that death or severe personal injury may result if proper precautions are not taken. 

   
Caution 

with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

 Caution 

without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

 Notice 

indicates that an unintended result or situation can occur if the corresponding information is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The device/system may only be set up and used in conjunction with this documentation. Commissioning and 
operation of a device/system may only be performed by qualified personnel. Within the context of the safety notes 
in this documentation qualified persons are defined as persons who are authorized to commission, ground and 
label devices, systems and circuits in accordance with established safety practices and standards. 

Prescribed Usage 
Note the following: 

   
Warning 

This device may only be used for the applications described in the catalog or the technical description and only in 
connection with devices or components from other manufacturers which have been approved or recommended 
by Siemens. Correct, reliable operation of the product requires proper transport, storage, positioning and 
assembly as well as careful operation and maintenance. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this 
publication may be trademarks whose use by third parties for their own purposes could violate the rights of the 
owner. 

Copyright Siemens AG 2004-2005. All rights reserved. 
The distribution and duplication of this document or the utilization and transmission of its 
contents are not permitted without express written permission. Offenders will be liable for 
damages. All rights, including rights created by patent grant or registration of a utility 
model or design, are reserved. 

 Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the 
hardware and software described. Since variance cannot be precluded entirely, we cannot 
guarantee full consistency. However, the information in this publication is reviewed 
regularly and any necessary corrections are included in subsequent editions. 

Siemens AG  
Automation and Drives 
Postfach 4848, 90327 Nuremberg, Germany  

Siemens AG 2005  
Technical data subject to change 
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Basic principles 1
1.1 1.1 Basic Principles of the Transfer Operation 

Transfer 
A transfer operation refers to the transfer of a complete project file to the HMI devices where 
the project is to run. 

After you have completed a configuration process, check the consistency of the project by 
using the menu "Project > Compiler > Check Consistency". After completing the consistency 
check, the system generates a compiled project file. This project file has the same name 
assigned to it as the project, however with the extension "*.fwx". Transfer the compiled 
project file to the configured HMI devices. 

The HMI devices must be connected to the configuration computer to transfer the project 
data. If the HMI device is a PC, it is also possible to perform the transfer operation using 
data media such as diskettes. 

Basic procedure 
1. Enter the transfer settings for the individual HMI devices in your WinCC flexible project. 

2. Enter the transfer mode on the HMI device where the project is to be transferred. 

3. Transfer the compiled project file from the configuration computer to the HMI devices. 
The project file is transferred to all HMI devices for which the respective check box is 
selected in the transfer settings. 

Transfer mode  
The HMI device must be in "transfer mode" for the transfer operation. Depending on the type 
of HMI device, transfer mode is enabled as follows: 

• Windows CE systems 

The HMI device starts up automatically in transfer mode when the device is 
commissioned the first time.  

The HMI device switches automatically to transfer mode at the start of each additional 
transfer operation if this transfer option is enabled on the configuration menu of the HMI 
device. 

If not, restart the HMI device and call the transfer applet on the Start menu, or configure 
the "Change Operating Mode" system function in your project.  
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• PCs 

If the HMI device is a PC that does not yet contain a project, you must enable the transfer 
mode in the "RT Loader" manually before the first transfer operation. 

Refer to your product manual for more detailed instructions on setting the transfer mode on 
the HMI device. 

HMI device version 
When transfering a project onto the operator device, the system checks if the configured 
operating system version corresponds with the version on the HMI device. If the system finds 
different versions the transfer is aborted and a message is displayed. You have following 
possibilities if the version of the operating system in the WinCC flexible project and on the 
HMI device are different: 

• Update the operating system on the HMI device 

You can find further information in chapter "Operating System Transfer". 

or 

• Select the corresponding HMI device version in the WinCC flexible project. 

You can find further information in chapter "Project HMI device dependency". 

See also 
Transferring a project (Page 2-3) 

Menu commands 
Menu commands for the transfer operation are located on the "Project > Transfer" menu. 
The following menu commands are available: 

 
Command Function 

Transfer settings Settings for transferring a compiled project file to the HMI devices. 
Only active if a project is selected.  

Upload Back transfer of projects from the HMI device to the configuration 
computer 

Backup Complete backup of the compiled project file, the operating 
system, and the settings, or just the recipes or passwords of the 
HMI device.  

Restore... Restore the compiled project file, operating system, and settings, 
or recipes or passwords (depending on the scope of the backup).  

Authorizations Transfer authorizations to the HMI device 
Options... Transfer options to the HMI device 
Updating the operating system Update the operating system on the HMI device 
Communication settings This menu command only appears if no project is open. 

Standard settings for back transfer, backing up, and restoring 
project files as well as for transferring the operating system, 
authorizations, and options to the HMI device. 
If no project is open in WinCC flexible, these settings are applied. 
Otherwise, the relevant transfer settings for the selected HMI 
device are applied.  
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The "ProSave" service tool, which can be used without installing WinCC flexible, also offers 
a part of the transfer functionality.  

For example, when replacing a device, you can use ProSave to back up a project from the 
original HMI device and restore it on a replacement device without having WinCC flexible 
installed on the computer. 

ProSave contains the following tabs: 

• General 

• Backup 

• Restore 

• Authorize 

• Options 

• OS Update 

Toolbar 
For transfer operations, WinCC flexible offers a toolbar containing the following button: 

 
Symbol  

 Opens the transfer settings dialog 

1.2 1.2 Transfer settings 

Introduction 
You can enter transfer settings individually for each HMI device of your project. The transfer 
settings include communication settings and the HMI device selection for the transfer 
operation.  

The "Transfer settings" dialog allows you to enter only those settings that are actually 
available for the selected HMI device.  

Selecting the HMI device for the transfer operation 
When a transfer operation is performed, the compiled project file is transferred to all HMI 
devices of the project for which the respective check box is selected in the transfer settings 
on the configuration computer.  

The relevant check box must be selected in the transfer settings on the configuration 
computer even if you use the context menu of the HMI device to start the transfer operation 
for this particular HMI device only. 
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Transfer modes 
Depending on the HMI device, you can use one or more of the following transfer modes:  

• Direct connection (USB cable (host-to-host), serial cable) 

Transfer takes place by means of a serial cable or a USB cable connecting the 
configuration computer and HMI device. 

 
  Note 

Always select the highest possible transmission rate for a transfer operation by means of 
a serial cable. At lower transmission rates, it can easily take hours for the quantity of data 
to be transferred. 

 
• Ethernet network connection 

The configuration computer and HMI device are located in a network or are connected 
point-to-point. The transfer operation between the configuration computer and the HMI 
device takes place by means of an Ethernet connection. 

• MPI/PROFIBUS DP 

The configuration computer and HMI device are in an MPI network or PROFIBUS DP 
network. The corresponding protocol is used for the transfer operation. 

• Http 

The http protocol is used for the transfer operation, for example, via the Internet or an 
Intranet. 

The transfer mode setting for an HMI device is also applied if the HMI device is selected in 
the project view and one of the commands on the "Project > Transfer" menu is selected (for 
example, in the case of a back transfer operation or when the operating system is updated 
on the HMI device). 

Transfer destination 
On Windows CE HMI devices, you can store the compiled project file to the Flash memory or 
RAM of the HMI device.  

Delta transfer on Windows CE devices 
To save time in the transfer, only delta transfers can be performed on Windows CE HMI 
devices. In the case of a delta transfer, only project data that has changed relative to the 
data on the HMI device is transferred.  

During a delta transfer, it is possible to transfer data to the RAM memory. This is advisable if 
a new configuration is to be tested without loss of the old configuration. After a 
shutdown/restart of the HMI device, the configuration transferred to the RAM is lost and the 
configuration stored in the Flash memory is again applicable.  

"Delta transfer" is the default setting for Windows CE HMI devices. You can change this 
default setting in the transfer settings to force the entire project to be transferred. It may be 
necessary to transfer the entire project, for example, if an executable project file no longer 
exists on the HMI device due to a malfunction or inconsistency after the delta transfer.  
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 Note 

If the HMI device is a PC, the complete data file is always transferred.  

Upload 
When transferring, you can transfer the compressed source data file along with the compiled 
project file to the HMI device. The compressed source data file is stored on the HMI device 
with the same name as the project but with the extension *.pdz added.  

If necessary, you can back transfer this source data file onto any configuration computer. 
Thus, you can analyze and continue processing the original project on a computer other than 
the original configuration computer at a later time. 

 
 Notice 

The source data file can be stored on the HMI device for back transfer purposes only if 
sufficient memory is available externally on the HMI device.  

Overwriting the password list and recipes 
When the compiled project file is transferred, the password list and recipes present on the 
HMI device are overwritten by the corresponding configuration data. Consequently, the 
option exists to create recipes and passwords as part of the project, which are then available 
on each HMI device to which the project has been transferred. During transfer, the 
compressed recipe data is transferred to the HMI device. When the transfer has ended, 
runtime starts on the HMI device and decompresses the recipe data. It then imports this into 
the project. After import, a system alarm is generated. Prior to concluding import you must 
not export any recipe data. You can only start an export or import of recipe data on the HMI 
device once the system alarm for a successful import / export has been issued.  

To prevent overwriting existing passwords and recipes, clear the respective check box. 
Another option for retaining the existing password list and recipes is to first back them up 
from the HMI device. Once the transfer operation has been performed, the password list and 
recipes can then be restored from the backup.  

See also 
Defining transfer settings (Page 2-1) 
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Transferring and back transfer of a project 2
2.1 2.1 Defining transfer settings 

Introduction 
You can specify transfer settings individually for each HMI device of your project. The 
transfer settings include communication settings and the HMI device selection for the 
transfer operation.  

The "Select devices for transfer..." dialog allows you to specify only those settings that are 
actually available for the selected HMI device.  

Requirement 
A project is open. 

Procedure 
1. Click the  icon in the "Transfer" toolbar. 

The "Select devices for transfer..." dialog is displayed. 

2. On the left, select the HMI device for which settings are to be made. 

The "Settings for..." area offers only those options that are actually available for the 
selected device. 

3. Select each check box in front of the HMI device to which the compiled project file is to be 
transferred during the transfer operation. 

4. Set the mode. 

5. Set the parameters for the selected transfer mode: 

– Serial: Interface and baud rate 

– MPI/DP bus: "Station address" 

– Ethernet: Computer name or IP address 

– USB: No other information is needed 



Transferring and back transfer of a project  
2.1 Defining transfer settings 

 Transfer 
2-2 System Manual, Edition 05/2005, Printout of the Online Help 

– http: Address, user name, and use of SSL; Port 80 is preset for the transfer operation. 
You can use a different port for the transfer operation by appending the port number to 
the address, separated by a colon. Example: To transfer using Port 79, enter: 
"www.xyz.de:79". 

Note that a setting is also required in the Internet Settings in the Control Panel on the 
HMI device: Activate the Enable Remote-Transfer (Project)" check box on the "Web 
Server" tab. The HTTP transfer from the configuration computer to the HMI device is 
enabled. 

– Adapt file: Destination directory 

6. For Windows CE devices only: Select the transfer scope. If delta transfer is enabled, only 
project data that has changed relative to the existing project is transferred to the HMI 
device, thus reducing the transfer time. 

7. For delta transfer on Windows CE devices only: Select whether the compiled project file 
is to be transferred to the Flash memory or the RAM of the HMI device. 

Only a delta transfer operation can be performed to RAM. This is advisable if a new 
configuration is to be tested without loss of the old configuration. After a shutdown/restart 
of the HMI device, the configuration transferred to the RAM is lost and the configuration 
stored in the Flash memory is again applicable.  

8. If you want the transfer operation to also store the compressed source file for the project 
externally on the HMI device during the transfer operation, select the "Enable back 
transfer" check box. The compressed source file can then be transferred back to any 
configuration computer, if necessary, and the project can thus be recovered. 

The HMI device must have sufficient external memory for the compressed project file to 
be saved.  

9. Select the appropriate check box if you want the password list or recipes that are present 
on the HMI device to be overwritten and thus reinitialized during the transfer operation. 

Result 
When a transfer operation is performed, the compiled project file is transferred to all HMI 
devices for which the check box is selected in the "Select devices for transfer..." dialog. The 
transfer mode set for each device is used for the transfer. The compiled project file is 
transferred to the memory selected as the transfer destination and according to the specified 
transfer scope. 

See also 
Back transfer of a project (Page 2-8) 

Transferring a project (Page 2-3) 

Error alarms during transfer of projects (Page 2-5) 

Transfer settings (Page 1-3) 

http://www.xyz.de:79/
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2.2 2.2 Transferring a project 

Introduction 
Then transfer the compiled project file to the HMI devices on which the project is to run. This 
process is a transfer.  

 
 Note 

If you initiate a transfer operation for a project that has not yet been compiled in its current 
version, the project is automatically compiled prior to the transfer. 

 
The HMI devices must be connected to the configuration computer to transfer the project 
data. If the HMI device is a PC, it is also possible to perform the transfer operation using 
diskettes. 

Requirement 
The configuration has been completed. 

The HMI devices to which the project data are to be transferred are connected to the 
configuration computer. 

The transfer settings for the HMI devices involved are correct. 

The checkbox has been activated for at least one HMI device in the "Select device for 
transfer..." dialog. 

If you want to transfer the source file for subsequent back transfer, there must be sufficient 
external memory on the HMI device. You can access the memory requirement for the project 
file in "Project" > "Project info." 

Procedure 
1. Use the same transfer mode setting on the HMI device as is used in the transfer settings 

of WinCC flexible for the respective HMI device. 

The procedure for setting the transfer method depends on the respective operating unit: 

– For units that have a control panel, the transfer mode is set using the control panel. 

– For other devices, such as PC and TP 170A, the transfer mode is set in the Loader 
menu when the device is started up. 

The memory location for the project file and source file is preset and can be overwritten.  

2. If transfer to several HMI devices should be performed simultaneously, click the  
button in the "Transfer" toolbar. The "Select device for transfer ..." dialog opens. 
Activate the checkbox of all HMI devices to which a transfer is required and click the 
"Transfer" button. 

If you want to transfer the project to only one HMI device, select the "Transfer" command 
in the shortcut menu for the HMI device. The checkbox must also be selected for this HMI 
device in the transfer settings; otherwise the transfer operation will not be carried out. 

If you have not yet compiled the project file, it is compiled automatically before the 
transfer operation. 
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Result 
The project file is transferred.  

Once the transfer operation is successfully concluded, the *.fwd file is located in the 
specified directory on the respective HMI device. Any existing project is overwritten.  

As soon as the transfer is finished, the runtime starts on the respective HMI device with the 
corresponding project file and displays the start screen.  

If the "Back transfer" checkbox was selected, the *.pdz file has been stored on the external 
memory of the HMI device. This file contains the compressed source data file for the project.  

As soon as the transfer operation has been completed, the respective HMI device starts up 
and displays the start screen.  

If an error occurred during the transfer operation, the corresponding alarms appear under 
"Transfer" in the Output Window.  

Remote control 
If a project is running in runtime on the operating unit, transfer can be initiated via remote 
control for the test and startup phases.  

The "Remote Control" option in Transfer Settings on the HMI device must be activated.  

During transfer via remote control, the project running is closed and the HMI device 
automatically switched to Transfer mode. If dialogs are still open on the HMI device, it is not 
possible to terminate the running project automatically. Close the dialog or cancel the 
transfer operation on the configuration computer.  

When transfer is finished, the newly transferred project file is automatically started.  

See also 
Example: Updating a ProTool V6.0 project (Page 4-1) 

Defining transfer settings (Page 2-1) 

Error alarms during transfer of projects (Page 2-5) 

Basic Principles of the Transfer Operation (Page 1-1) 
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2.3 2.3 Error alarms during transfer of projects 

Possible problems while transferring 
While a project is being transferred to the HMI device, status messages regarding the 
progress of the transfer operation are displayed in the output window.  

Problems that may occur when a project is being transferred to the HMI device are usually 
caused by too high a transmission rate or the simultaneous use of other drivers on the 
configuration computer (when connected to a network, for example).  

The most common transfer failure cases are listed below. 

The serial transfer is terminated. 
Possible remedy: Select a lower baud rate.  

The transfer is terminated, and a compatibility conflict alarm is issued. 
 

Possible cause Remedy 

Conflict between versions of the 
configuration software and the 
operating system of the HMI 
device. 

Synchronize the operating system of the HMI device with the 
version of the configuration software. 
Use the "Transfer > Update operating system" command on the 
"Project" menu to update the operating system. 
For additional information, refer to the operating instructions for 
the HMI device.  
Alternatively, you can use the "ProSave" service tool to update 
the operating system. For additional information, refer to the 
online Help for ProSave. 

The configuration computer is 
connected to an illegal device 
(such as a PLC).  

Check and correct cabling and communication parameters  

The transfer operation does not take place 
 

Possible cause Remedy 

Connection to the HMI device 
cannot be established (alarm in the 
output window) 

Check the physical connection between the configuration 
computer and the HMI device. The HMI device must also be in 
transfer mode (except in the case of remote control). 

The default communication driver 
is not listed in the Windows Device 
Manager. 

Check the device status of the COM connection in the 
properties window of the Device Manager. 
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MPI/DP download is not functioning. 
 

Possible cause Remedy 
The CP to be used for the 
download is set to "configured 
mode" (for example, when 
SIMATIC NET CD 7/2001 is 
used). 

Go to the "Set PC station" tool and set the CP to "PG mode." 
Check the network parameters (baud rate, MPI address). 
Perform the download from the WinCC flexible ES. 
Set the CP back to "configured mode." 

In the programming device/PC 
panel, the S7ONLINE access 
point is not on a physical device 
(such as CP 5611 (MPI)). This 
can occur, for example, when the 
SIMATIC NET CD 7/2001 is 
installed. 

Go to the "PG/PC panel" tool or, when the SIMATIC NET CD 
7/2001 is being used, the "Set PC station" tool, and place the 
S7ONLINE access point to your required device. 
Check the network parameters (baud rate, MPI address). 
Perform the download from the WinCC flexible ES. 
Reposition the S7ONLINE access point back to the original 
device. 

Complexity of the configuration is too great 
 

Possible cause Remedy 
The configuration contains too 
many different objects and 
options for the device selected. 

Clear all objects of a type (e.g. all HTML browsers). 
Alternatively, clear the options (e.g. Sm@rtServer or OPC 
server). 

See also 
Transferring a project (Page 2-3) 

Defining transfer settings (Page 2-1) 

2.4 2.4 Back transfer of projects 

Introduction 
When transferring, you can transfer the compressed source data file along with the compiled 
project file to the HMI device. This source data file is required for the project to be back 
transferred from the HMI device to a configuration computer. 

Use for back transfer 
Normally, only the executable project is transferred to the HMI device during a transfer 
operation. The original project data remain on the configuration device and are thus available 
to develop the project further in future or for error analysis.  

However, on Windows CE devices with an external storage medium and on PCs, you can 
store not only the compiled project file but also the compressed source data file for the 
project. This data file can be used at a later time to recover the project from the HMI device 
or device by back transferring the source data file to a configuration computer.  
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Advantage:  
The back transfer operation enables you to subsequently perform analyses and make 
changes to an existing project even if the original configuration device is not available or the 
source file (*.pdf) for the project is no longer available on the configuration device.  

 
 Note 

You can also use WinCC flexible to transfer the source data file of a ProTool V6.0 project 
back from the HMI device onto a configuration computer. You can then perform a migration 
of the ProTool project to a WinCC flexible project. 

The source data of a ProTool project which was configured for an operating device not 
supported by WinCC flexible must be transferred back to a configuration computer with 
ProTool. Save the ProTool project. Then execute a migration using WinCC flexible. 

Requirements for back transfer 
• The source data file can only be transferred to the HMI device as part of the transfer 

operation for the compiled project file. The source data file is transferred along with the 
compiled project file to the HMI device if the "Enable back transfer" check box is selected 
in the transfer settings for the respective HMI device. 

• There must be sufficient memory available on the HMI device to store the compressed 
source data file. If the source data file for the back transfer operation is provided by a 
Windows CE device, this device must have an external memory card. If the HMI device 
does not have a memory card or if there is insufficient memory space, the transfer is 
terminated. However, the compiled project file is transferred in its entirety beforehand so 
that runtime can be started with the transferred project data. 

If the source data of a large project should be stored for back transfer and an Ethernet 
connection is available to the operating device, you can select a network drive as the 
storage location rather than the memory card of the operating device. This avoids 
problems with the storage location. 

• If there is no project opened in WinCC flexible, you must select the HMI device on which 
the source data file for the back transfer operation is located and the loading method in 
the "Communication settings" dialog prior to carrying out the back transfer operation. 

If a project is open in WinCC flexible, the back transfer operation takes place from each 
selected HMI device. In this case, the transfer mode selected for this HMI device in the 
"Transfer Settings" dialog in WinCC flexible is applied.  

Transfer and back transfer 
When a source file is included in the transfer operation, the project is compressed from the 
source format (*.pdf) and transferred as a *.pdz file to the external storage medium of the 
HMI device or directly to the PC.  

In the case of a back transfer operation, the *.pdz file is saved on the configuration 
computer. If a project was open in WinCC flexible during the back transfer, you are prompted 
to save and close it. Then, the project back transferred is decompressed and opened in 
WinCC flexible. When saving the project, you must assign a name for the back transferred 
project.  
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Caution 

WinCC flexible cannot check whether the source data file on the operating unit actually 
belongs to the project running on the device. If you have performed a transfer operation in 
the interim that did not include the source data file, old project data may still be on the HMI 
device. Under certain circumstances, the data will then no longer match the project that is 
currently running. 

 
 Note 

Use the back transfer process preferably for small and medium sized configurations in order 
to keep transfer times as short as possible. 

You have the following options when there are numerous project files: Transfer the project 
file as a compressed *.arj file onto a CF card, for example, using the backup function of the 
project manager. 

See also 
Example: Updating a ProTool V6.0 project (Page 4-1) 

Back transfer of a project (Page 2-8) 

2.5 2.5 Back transfer of a project 

Introduction 
If the source data file was included when the compiled project file was transferred to the HMI 
device, you can back transfer this source data file from the HMI device to any configuration 
computer. In this way, you can access the project again even if the data file is not available 
on the original computer. 

You can also back transfer the source data file of a ProTool V6.0 project from the HMI 
device onto a configuration computer. You can then migrate the ProTool project to a WinCC 
flexible project on the configuration computer. 

 

 
Caution 

WinCC flexible cannot check to determine whether the source data file on the HMI device 
actually belongs to the project running on the device. If you have performed a transfer 
operation that did not include the source data file, old project data may still be on the HMI 
device. Under certain circumstances, the data will then no longer match the project that is 
currently running. 
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Requirement 
WinCC flexible is open on the configuration computer. 

The compressed source file was successfully stored on the HMI device during the transfer 
operation. 

If there is no project opened in WinCC flexible, you must select the HMI device where the 
source data file for the back transfer operation is located and the back transfer mode in the 
"Communication settings" dialog.  

If a project is open in WinCC flexible, the back transfer takes place from each HMI device 
selected in the project view. In this case, the transfer mode for this HMI device must be set 
correctly in the "Select devices for transfer..." dialog.  

Procedure 
1. Apply the same back transfer mode setting for the HMI device that is in the transfer 

settings or communication settings of WinCC flexible. 

The procedure for setting the transfer method depends on the respective operating unit: 

– For devices that have a system control, the transfer mode is set using an applet in the 
system control. 

– For other devices, such as a PC and TP 170A, the transfer mode is set in the Loader 
menu when the device is started up. 

2. Start the back transfer using the "Transfer > Back transfer" command on the "Project" 
menu. 

The back transfer brings the HMI device into transfer mode via remote control. 

Once the back transfer is successfully completed, any open project in WinCC flexible is 
closed, and the back transferred project is opened with a temporary name assigned.  

3. Edit the project in WinCC flexible, and then save it with a new name. 

Result 
The back transferred project is saved on the configuration computer. 

If the source data file of a WinCC flexible project was transferred back, the project is then 
opened automatically in WinCC flexible. 

If the source data file of a ProTool V6.0 project was transferred back and the "migration" 
option is installed on the configuration computer, the migration for this project is started 
automatically. 

See also 
Example: Updating a ProTool V6.0 project (Page 4-1) 

Defining transfer settings (Page 2-1) 

Back transfer of projects (Page 2-6) 
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Managing Files on the HMI Device 3
3.1 3.1 ProSave 

Introduction 
The ProSave service tool is supplied with WinCC flexible. The functionality of ProSave is 
integrated into the WinCC flexible user interface on the programming device. ProSave can 
also be installed as a stand-alone program on a computer where WinCC flexible is not 
installed ("stand-alone operation"). 

Functional scope 
ProSave provides all of the functions needed to transfer files to the HMI device.  

• Data backup and restoration of backed-up data 

• Operating system update for Windows CE-based devices 

• Transferring authorizations 

• Installing and uninstalling drivers and options as well as information on installed options 
and options that can be installed on an HMI device 

• Communication settings 

Integrated operation on the configuration computer 
ProSave is installed on the configuration computer as part of a standard WinCC flexible 
installation. The complete functional scope of ProSave is integrated within WinCC flexible on 
the "Project > Transfer" menu. 

Stand-alone operation on a computer  
ProSave can also be installed on a computer from the WinCC flexible CD and used without 
WinCC flexible being installed (for example, for service purposes). 

When replacing a device, for example, you can use ProSave to back up a project from the 
original HMI device and restore it on a replacement device without having WinCC flexible 
installed. 

If you are using ProSave outside of WinCC flexible, you have the option to change the user 
interface language. To select a language, use the "Language" menu command in ProSave. 
ProSave must be restarted for the language switch to take effect.  
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3.2 3.2 Entering communication settings 

Introduction 
If you are running ProSave as a stand-alone application or if there is no project open in 
WinCC flexible, you must first enter communication settings. In the "Communication settings" 
dialog, you specify the HMI device to which or from which the transfer operation is to take 
place and the mode to be used to transfer the files.  

If you are working on the configuration computer and a project is open in WinCC flexible, the 
transfer operation takes place from or to the selected HMI device. The transfer mode 
settings in the transfer settings is applied and not the transfer mode selected in the 
communication settings.  

Requirement 
If you are working with ProSave as a stand-alone application: ProSave is open. 

If you are working on the configuration computer: WinCC flexible is open. 

Procedure 
1. If you are working with ProSave as a stand-alone application: Select the "General" tab. 

If you are working on the configuration computer: Select the "Transfer > Communication 
settings" command on the "Project" menu in WinCC flexible. 

2. Select the HMI device type for which you want to make communication settings. 

3. Set the mode. 

4. Set the parameters for the selected transfer mode: 

– Serial: Interface and baud rate 

– MPI/DP bus: "Station address" 

– Ethernet: PC name or IP address 

– USB: No other information is needed 

– http (not for ProSave): Address and use of SSL; Port 80 is preset for the transfer 
operation. You can use a different port for the transfer operation by appending the port 
number to the address, separated by a colon. Example: To transfer using Port 79, 
enter: "www.xyz.de:79". 

– Adapt file: Destination directory 

Result 
The communication settings are used for transferring the file from or to the HMI device. If 
you are working with WinCC flexible on the configuration computer, the communication 
settings only take effect if a project is not open. 

http://www.xyz.de:79/
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See also 
Backing up and restoring data on an HMI device (Page 3-4) 

Updating the operating system on the HMI device (Page 3-7) 

Managing licenses (Page 3-9) 

Installing and uninstalling an option (Page 3-11) 

3.3 3.3 Backup of HMI data 

Introduction 
The data on an HMI device should be backed up at regular intervals.  

A data backup allows you to quickly resume operation after a system failure or when a 
device was replaced. The backup data are simply transferred to the new HMI, and thus 
restore the original state.  

Data backup using WinCC flexible or ProSave 
You can use WinCC flexible and a programming device which is connected to the HMI to 
backup and restore all HMI data.  

If the computer does not have WinCC flexible installed, you have the convenient option of 
using ProSave to perform a centralized backup.  

Scope of data backup 
The backup and restore operation depends on the type of HMI device and can include the 
following project data: 

• Complete backup (depending on the HMI device: Runtime, firmware, operating system 
image, configuration, recipes, passwords, and settings, but not authorizations) 

• Recipes only 

• Passwords only 

A backup file with the extension *.psb is generated when you backup the HMI data.  

The backup can be made to any memory medium, such as a data server, if an appropriate 
connection exists between the HMI device and the memory medium. 

 
 Note 

Only use the restore function for project data on operating devices configured using the 
same configuration software.  

If, for example, WinCC flexible recipe data is restored on a device configured using ProTool, 
the Flash memory can no longer be read. Delete the Flash memory, in this case, and 
transfer the ProTool project again.  
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 Note 

Note the following when performing a complete data file backup and restore operation for 
Windows CE devices: 

Authorizations are not backed up! 

When a complete data restoration is carried out, all of the data that were previously on the 
device, including authorizations and the operating system, are irrevocably deleted. 

If an interruption occurred while data was being restored, you must first reload the operating 
system onto the HMI device via the serial port using the "bootstrap" mechanism before 
resuming the data restoration. 

All installed options are also backed up, but not the associated authorizations. Basically, all 
the data for the option that are still available after "POWER OFF" are backed up. 

 
 Note 

If at all possible, you should use USB or Ethernet to back up and restore data because use 
of these interfaces will result in the shortest transfer times. 

 
 Note 

For Windows CE devices, a direct data backup can be performed from the device to an 
external storage medium, namely a CF card or PC card. For additional information, refer to 
the relevant operating instructions. 

See also 
Backing up and restoring data on an HMI device (Page 3-4) 

3.4 3.4 Backing up and restoring data on an HMI device 

Introduction 
The data on an HMI device must be backed up at regular intervals. 

You can use WinCC flexible and a programming device which is connected to the HMI to 
backup and restore all HMI data.  

If the computer does not have WinCC flexible installed, you have the convenient option of 
using ProSave to perform a centralized backup.  

 
 Note 

Only use the restore function for project data on operating devices configured using the 
same configuration software.  

If, for example, WinCC flexible recipe data is restored on a device configured using ProTool, 
the Flash memory can no longer be read. Delete the Flash memory, in this case, and 
transfer the ProTool project again.  
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Requirement 
The HMI device is connected to the configuration computer or the computer with ProSave.  

• If you are working with ProSave as a stand-alone application or on the configuration 
computer without an open WinCC flexible project: The communication settings in 
ProSave or WinCC flexible are correct. 

• If you are working on the configuration computer with an open WinCC flexible project: 
The HMI device containing the data to be backed up or restored has been selected in the 
project window, and the associated transfer settings are correct. 

• If you are using a separate storage medium, such as a data server: The HMI device is 
connected to the storage medium. 

Procedure for data backup 
1. If you are working with ProSave as a stand-alone application: Select the "Backup" tab in 

ProSave. 

If you are working on the configuration computer: Select the "Transfer > Backup" 
command on the "Project" menu in WinCC flexible. 

2. Select the scope of the backup: "Complete backup," "Recipes," or "Passwords." 

Click "...", select the storage location in the "Select backup file" dialog, and specify a file 
name. 

3. If you are working with ProSave as a stand-alone application: Click "Start backup." 

If you are working on the configuration computer: Click "OK." 

This starts the data backup. The backup operation can take time, depending on the 
connection selected. 

Procedure for restoring data 
1. If you are working with ProSave as a stand-alone application: Select the "Restore" tab in 

ProSave. 

If you are working on the configuration computer: Select the "Transfer > Restore..." 
command on the "Project" menu in WinCC flexible. 

2. Click "...", and select the storage location and file in the "Open" dialog. 

The "Content" area indicates which HMI device is the origin of the data backup and the 
scope of the data backup. 

3. If you are working with ProSave as a stand-alone application: Click "Start restore." 

If you are working on the configuration computer: Click "OK." 

This starts the restoration. The update operation can take time, depending on the connection 
selected. 

See also 
Backup of HMI data (Page 3-3) 

Entering communication settings (Page 3-2) 
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3.5 3.5 Updating the operating system 

Introduction 
If the operating system version on a Windows CE device is not compatible with the 
configuration, the transfer of the configuration is cancelled. A message appears indicating 
the operating system must be updated.  

Updating the operating system 
 
 Note 

The operating system can only be updated on Windows CE-based devices 
 

You can use WinCC flexible and a computer connected to the HMI to update the HMI 
operating system.  

If the computer does not have WinCC flexible installed, you have the option of using 
ProSave to update the operating system of the HMI device.  

 
 Notice 

Do not use a serial connection to transfer the operating system. The transfer operation can 
take up to an hour if a serial cable is used.  

 
When an operating system is updated, all of the data on the destination device, including 
authorizations, are deleted. Therefore, use the "Authorizations" function to transfer the 
authorizations back onto the license diskette beforehand. 

If you want to continue to use any user data (such as passwords and recipes) stored in the 
internal Flash memory once the operating system is updated, you must export the data to an 
external data memory beforehand and reload them onto the HMI device following the 
update. 

"Bootstrapping" 
If the operating system update was terminated prematurely, an operating system will no 
longer be available on the HMI device. A "bootstrap" operation is then the only option 
available for loading an operating system. 

When an operating system is updated, the communication between the configuration 
computer and the HMI device takes place by means of the operating system of the HMI 
device. During a "bootstrap" operation, however, the configuration computer communicates 
with the boot loader of the HMI device. In this case, communication is only possible by 
means of a serial connection. The bootstrap operation can take time.  

Once the "bootstrap" operation has been started in WinCC flexible, power on the the HMI 
device must be switched off and on again (booted), so that the HMI device can communicate 
by means of the boot loader.  
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See also 
Updating the operating system on the HMI device (Page 3-7) 

3.6 3.6 Updating the operating system on the HMI device 

Introduction 
If the operating system version on a Windows CE device is not compatible with the 
configuration, transfer is interrupted. A message appears indicating the operating system 
must be updated.  

If an operating system is not available on the HMI device, a "bootstrap" operation must be 
used to transfer the operating system to the HMI device. A "bootstrap" operation requires a 
serial connection between the configuration computer and the HMI device. 

 
 Note 

Back up the authorizations onto the authorization diskette beforehand. When the operating 
system is updated, existing authorizations are irrevocably deleted from the device.  

Requirement 
The HMI device is connected to the configuration computer or the computer with ProSave.  

• If you are working with ProSave as a stand-alone application or on the configuration 
computer without an open WinCC flexible project: The communication settings in 
ProSave or WinCC flexible are correct. 

• If you are working on the configuration computer with an open WinCC flexible project: 
The HMI device containing the operating system to be updated has been selected in the 
project view, and the associated transfer settings in the project are correct. 

 
  Notice 

Do not use a serial connection to update the operating system. The transfer operation 
can take up to an hour if a serial cable is used.  
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Updating the HMI device 
1. If you are working with ProSave as a stand-alone application: Select the "OS update" tab 

in ProSave. 

If you are working on the configuration computer: Select the "Transfer > Update operating 
system" command on the "Project" menu in WinCC flexible. 

2. Select the path for the image of the Windows CE operating system to be transferred to 
the HMI device. 

All devices for which the selected operating system is valid are shown, including the 
operating system version. 

3. If you are working with ProSave as a stand-alone application: You may also click "Device 
status" to display the version of the operating system currently on the HMI device. 

4. If you are working with ProSave as a stand-alone application: Click "Update." 

If you are working on the configuration computer: Click "OK." 

This starts the update. The update operation can take time, depending on the connection 
selected. 

Procedure for "bootstrapping" 
1. Switch off power to the HMI device. 

2. Connect the serial interface of the HMI device to a serial interface of the configuration 
computer using a serial cable. 

The "bootstrap" operation can only take place over a serial channel.  

3. On the configuration computer, select the "Transfer > Update operating system" 
command on the "Project" menu in WinCC flexible. 

4. Select the path for the image of the Windows CE operating system to be transferred to 
the HMI device. 

All devices for which the selected operating system is valid are displayed along with the 
operating system version.  

5. Select the "Bootstrap" check box. 

6. Click "OK." 

7. Switch on the power supply to the HMI device to start the "bootstrap" operation for the 
operating system. 

The bootstrap operation can take time. 

Result 
The operating system of the HMI device is now updated to the current version. 

See also 
Example: Updating a ProTool V6.0 project (Page 4-1) 

Updating the operating system (Page 3-6) 

Entering communication settings (Page 3-2) 
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3.7 3.7 Transferring license keys 

Transferring license keys 
The installation of some WinCC flexible runtime options requires license keys provided on a 
license key disk. You transfer the required license keys to the HMI device during installation 
by means of the configuration computer.  

If necessary, you can transfer the license keys back onto the license key diskette, for 
example, to use the license keys on another HMI device.  

 

 
Caution 

To prevent irrevocable loss of license keys, you must transfer the license keys for an HMI 
device back onto the license key diskette in the following cases: 

- Before updating the operating system on a Windows CE HMI device 

- Before restoring a complete data file from the backup 
 

License keys on an HMI device are not backed up as part of a backup operation. 

See also 
Managing licenses (Page 3-9) 

3.8 3.8 Managing licenses 

Introduction 
For some options, an license is required to install the option on an HMI device. Each license 
is assigned a license key provided on the license key diskette. You must transfer the license 
key from this diskette via a computer to the HMI device. To backup the license key, you can 
then transfer it from the HMI device via a computer and back on to the license key diskette. 
Use the Automation License Manager when handling license keys. The Automation License 
Manager is automatically included in the WinCC flexible Setup. 

You do not have to install WinCC flexible in order to handle license keys. Once you have 
installed the Automation License Manager (WinCC flexible CD2 under 
"WinCCflexible\Options\Automation License Manager") and ProSave (WinCC flexible CD2 
under "WinCCflexible\Setup\ProSave\Disk1"), you can use the Automation License Manager 
as a stand-alone application for transferring license keys.  

Requirement 
The HMI device and the configuration computer or the computer with the Automation 
License Manager are connected to each other.  

• If you are working with the Automation License Manager as a stand-alone application or 
on the configuration computer without an open WinCC flexible project: the communication 
settings in the Automation License Manager or in WinCC flexible are correct. The 
Automation License Manager is launched. 
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• If you are working on the configuration computer with an open WinCC flexible project: 
The HMI device to which or from which the license is to be transferred has been selected 
in the project window, and the associated transfer settings are correct. 

Procedure 
1. When working with the Automation License Manager as a stand-alone application: Select 

"Edit ► Connect Target System ► Connect Panel." 

If you are working on the configuration computer: Select the command "Transfer > 
License Key" under "Project" in WinCC flexible. 
The "Connect Target System" dialog appears. 

2. Under "Device Type," select the appropriate device type. 

Under "Connection", select the type of connection.  
 Dependent on the chosen type of connection under "Connection Parameters" the 
respective fields for the connection settings are released. 

 
3. Select the required connection parameters and then click on "OK".  

A connection with the HMI device is created. The connected HMI device is displayed in 
the left window of the Automation License Manager. 

4. In the left window, select the source drive. The right window displays the existing license 
keys. 

5. Drag one or more license keys from the right window and drop them on the HMI device in 
the left window. The license keys are then transferred to the HMI device. 

You can also remove license keys from the HMI device using drag & drop. 
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Result 
The license keys are transferred from or to the license key diskette. 

See also 
Transferring license keys (Page 3-9) 

Entering communication settings (Page 3-2) 

3.9 3.9 Installation of options 

Available options 
You can install additional options supplied with WinCC flexible on HMI devices at a later 
time. Likewise, you can install options purchased separately from WinCC flexible at a later 
time.  

The HMI device type determines which options can be installed.  

For an overview of available options, refer to "Introduction to WinCC flexible." 

See also 
Installing and uninstalling an option (Page 3-11) 

3.10 3.10 Installing and uninstalling an option 

Introduction 
You can install additional options supplied with WinCC flexible on HMI devices at a later 
time. Likewise, you can install options purchased separately from WinCC flexible at a later 
time.  

The HMI device type determines which options can be installed.  

Requirement 
The HMI device is connected to the configuration computer or the computer with ProSave.  

• If you are working with ProSave as a stand-alone application or on the configuration 
computer without an open WinCC flexible project: The communication settings in 
ProSave or WinCC flexible are correct. 

• If you are working on the configuration computer with an open WinCC flexible project: 
The HMI device on which an option is to be installed has been selected in the project 
window, and the associated transfer settings are correct. 
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Procedure 
1. If you are working with ProSave as a stand-alone application: Select the "Options" tab in 

ProSave. 

If you are working on the configuration computer: Select the "Transfer > Options..." 
command on the "Project" menu in WinCC flexible. 

All available options and the previously installed options are displayed. 

2. You may also click "Device status" to display the options installed on the HMI device. 

3. Move all of the options you want to install on the HMI device to the list of already installed 
options using the ">>" button. 

4. Use the "<<" button to uninstall an option from the HMI device. 

5. Click "OK" to start installing or uninstalling the options. 

Result 
The selected options have been installed on the HMI device or uninstalled from the HMI 
device. 

See also 
Installation of options (Page 3-11) 

Entering communication settings (Page 3-2) 
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Example 4
4.1 4.1 Example: Updating a ProTool V6.0 project 

Introduction 
In the following example, a ProTool V6.0 project has been created and the compressed 
source data file has been stored on an MP 370. The example shows you how to transfer 
back the project, migrate the project to a WinCC flexible project, and then transfer the project 
back to the HMI device. . 

Requirement 
The compressed source file for the ProTool V6.0 project is stored on the MP 370. 

The MP 370 is connected to the configuration computer by means of USB. 

WinCC flexible with migration is installed on the configuration computer. 

Sequence 
To update the project, the following steps must be performed consecutively: 

• Back transfer of the compressed source data file from the MP 370 to the configuration 
computer 

• Migrate the project from ProTool V6.0 to WinCC flexible 

• Updating the operating system of the MP 370 

• Transfer the compiled WinCC flexible project from the configuration computer to the  
MP 370 

Back transfer of the source data file 
1. Open WinCC flexible on the configuration computer. 

Select the "Transfer > Communication settings" command on the "Project" menu. 

2. Select the operating system "MP 370". 

3. Set "USB" as the "Mode." 

4. Likewise, set "USB" as the method on the MP 370 using the transfer applet. 
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5. Start the back transfer on the configuration computer using the "Project > Transfer > Back 
transfer" command. 

The back transfer brings the HMI device into transfer mode via remote control before the 
source data file is transferred back. 

The source data file is transferred back onto the configuration computer. The project 
migration starts automatically in WinCC flexible.  

Migrate the project from ProTool V6.0 to WinCC flexible 
The "Migration Wizard" guides you through the migration procedure. 

1. Perform the steps suggested by the "Migration Wizard." 

You can track the individual steps in the "Migration Wizard" and receive information on 
how long the migration will take. 

2. Open the "Log file" and find out about the migration operation. The "Log file" contains 
entries regarding the scope and success of the migration as well as information on 
changes that were made to the data file. 

3. Save the project with a suitable name. 

4. If necessary, revise the project. 

5. Compile and test the project. 

If the project is error-free, you can transfer it back to the HMI device. 

Updating the operating system of the MP 370 
Before a project created with WinCC flexible can be run on an MP 370 that was configured 
previously using ProTool, you must update the operating system. 

 
 Note 

Back up any authorizations remaining on the MP 370 to the authorization diskette. When the 
operating system is updated, existing authorizations will be irrevocably deleted from the 
device.  

 
1. On the configuration computer, select the "Transfer > Update operating system" 

command on the "Project" menu. 

2. Select the Windows CE operating system to be transferred to the MP 370. 

All devices for which the selected operating system is valid are shown, including the 
operating system version. 

3. Click "OK." 

The MP 370 operating system is being updated. 
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Transfer the WinCC flexible project to the MP 370 
Prior to transferring the WinCC flexible project, you must enter the transfer settings for the 
MP 370. 

1. Click on the <Transfer settings> button on the "Transfer" toolbar. 

The "Select devices for transfer..." dialog is displayed. 

2. On the left, select "MP 370" as the HMI device. 

The "Settings for..." area offers only those options that are actually available for the 
MP 370. 

3. Select the check box in front of the "MP 370" entry so that the compiled project file is 
transferred to the MP 370 during the transfer operation. 

4. Set "USB" as the "Mode." 

5. Select the Flash memory of the MP 370 as the transfer destination. 

6. Disable delta transfer. 

7. To store the compressed source file for the project on the MP 370 during the transfer 
operation, select the "Enable back transfer" check box. 

8. Click "Transfer." 

The compiled project file is transferred to the MP 370 where it can be recommissioned. 

Result 
The migrated project can be recommissioned after it is transferred back, migrated, and 
transferred again. 

 

See also 
Updating the operating system on the HMI device (Page 3-7) 

Back transfer of projects (Page 2-6) 

Transferring a project (Page 2-3) 

Back transfer of a project (Page 2-8) 
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