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Preface

Information in this document is subject to change without notice.

© 1998–2007 NxtPhase T&D Corporation. All rights reserved. 

Reproduction in any manner whatsoever without the written permission of 
NxtPhase T&D Corporation is strictly forbidden.

This manual is part of a complete set of product documentation that includes 
detailed drawings and operation. Users should evaluate the information in the 
context of the complete set of product documentation and their particular 
applications. NxtPhase assumes no liability for any incidental, indirect, or 
consequential damages arising from the use of this documentation.

While all information presented is believed to be reliable and in accordance 
with accepted engineering practices, NxtPhase makes no warranties as to the 
completeness of the information.

All trademarks used in association with B-PRO, F-PRO, L-PRO, ProLogic, T-
PRO, TESLA, TESLA Control Panel, RecordGraph, RecordBase, NXCT, 
NXVT, and NXVCT are trademarks of NxtPhase T&D Corporation.

Windows® is a registered trademark of the Microsoft Corporation.

Contact Information

NxtPhase T&D Corporation

Website: www.nxtphase.com

Email: info@nxtphase.com

Technical Support

Email: support@nxtphase.com

Tel: 204-477-0591
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Version Descriptions

RecordBase View Revision History

Date  Version Changes from Previous Version

2007-Mar-02 v1.5f Support for T-PRO Through Fault and Event records
(RecordGraph v2.6): corrected tootip display of BVase Current 
for B-PRO Differential Characteristics plot.
(Export v5.9): added export of Excel CSV for T-PRO Through 
Fault Event records.

2004-Oct-22 v1.5e Fixed incorrect start time when exporting combined TESLA 
records in COMTRADE format.2007
(RecordGraph v2.2i): corrected absolute time readout for com-
bined TESLA records.
(RecordGraph v2.2i): Impedance View now works with COM-
TRADE files.

2004 Jul 30 v1.5d Supports latest record version produced by B-PRO 8700.
Enhanced RecordGraph analysis module.

2004 Mar 12 v1.5c Enhanced RecordGraph analysis module.

2003 Jun 18 v1.5a Enhanced RecordGraph analysis module.

2003 Jan 17 v1.5 Multiple database support through File>Open.. option. 
Ability to transfer records between any two databases.

2002 Oct 30 v1.4a Supports the latest version of record produced by the TESLA 
recorder.

2002 Sep 20 v1.4 New Impedance View and Differential View.
New and improved features. 

2001 Dec 17 v1.3 Incorporates new graphics analysis module.

2001 Oct 26 v1.2 Supports Setting Groups.

2001 Apr 10 v1.1 RecordBase View compatible to RecordBase Server database.
Transfer Record feature added to the Tool bar.
Database Location added to the Options menu. 

2001 Feb 06 v1.0 First release. Replaces Offliner View software.

RecordBase View User Manual Revision History

Date
Manual 
Version

Changes from Previous Version

2007-Mar-02 v1.5 Rev 4 Update to include new features.

2004 Jul 30 v1.5 Rev 3 Update to include new features.

2003 Jun 18 v1.5 Rev 2 Update to include new features.
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2003 Jan 17 v1.5 Rev 1 Update to include new features.

2002 Oct 30 v1.4 Rev 2 Update to include new features.

2002 Sep 20 v1.4 Update to include new features.

2002 May 15 v1.3 Rev 2 Update to new format.

2001 Dec 17 v1.3 Incorporates software changes.

2001 Oct 26 v1.2 Incorporates software changes.

2001 Apr 10 v1.1 Incorporates software changes.

2001 Feb 06 v1.0 First release. Replaces Offliner View software.
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1 Starting RecordBase View

Overview
RecordBase View is a Windows-based software tool for displaying and man-
aging records from NxtPhase relays. RecordBase View features include:

   •  record displays and analysis 

   •  storage and management of records in database

   •  record summaries including event lists and user annotation

   •  COMTRADE, PTI and MS Excel export

   •  Windows Explorer integration

   •  compatibility with RecordBase Server database.

RecordBase View runs on PCs with Windows 95/98/ME/NT4.0/2000 operat-
ing systems. A minimum of a Pentinum II with 64MB of RAM and a display 
capable of 800 x 600 resolution is recommended. RecordBase View makes use 
of Microsoft Access. By default, it uses a run-time version of Access 97 that is 
part of installation—you do not need to have your own copy of Access.

Figure 1.1:  RecordBase View Opening Window

Record Search

 - uses Product, Unit ID and time 

range to search for records

Record List 

- displays a list of found records sorted 

by Trigger Time, Unit ID or Type 

Export Utility 

- converts records 

into COMTRADE, PTI 

and Excel formats.

Reports - generates  

two types of reports: 

Record List and 

Record SummarySave Settings 

View Settings 

Main Menu Tool Bar

Record Summary 

- information about

   the record selected

Add - add records to database Transfer records..
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1 Starting RecordBase View
Launching RecordBase View

There are two methods to launch RecordBase View:

Method 1: Desktop Double-click the icon  labelled RecordBase View on your desktop.

Method 2: Windows 
Start Menu

Start>Programs>NxtPhase>RecordBase View

Figure 1.2:  Launch RecordBase View

Main Menu Tool Bar

Figure 1.3:  Main Menu Tool Bar

For proper operation of RecordBase View, ensure that the Windows 
Date format is set to YYYY-MM-DD format. Change the date format 
by going to Windows Control Panel, Regional Settings, Date Tab.

Method 1: Click on the

icon to launch 

RecordBase View

Method 2: Open 

Windows Explorer to 

launch RecordBase 

View

RecordBase View Icon

Menu

File
Edit

Records
Options

Help

Graph
View Settings

Save Settings
Reports

Export
Send

Save to

Add

Transfer records...

Delete
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1 Starting RecordBase View
Icon Restore
Move
Size
Minimize
Maximize
Close

File Open.. opens selected database.
Exit.

Edit Cut
Copy
Paste

Records Graph
View settings
Save Settings
Reports -Record List and Record Summary
Add
Delete
Transfer records..
Save To
Export
Send

Options Add Record

Help User Manual
About RecordBase View.

Toolbar Buttons

Graph Select a record(s) from the record list, then select the 
Graph button to launch RecordGraph, a tool used to dis-
play and analyse records. 
Alternatively, double-click a record to launch 
RecordGraph.

View Settings If Offliner Settings is installed on your system, view the 
setting file (as read-only) of the selected record using the 
View Settings tool.

Save Settings Extract the settings from the selected record and save the 
settings to a file for later use (viewing/editing). If Offliner 
Settings is installed on your system, use it to view and 
edit the setting file.

Reports Generates to two types of reports:
Record List - a report containing a list of records shown 
on the LHS of the screen categorized by Trigger Time, 
UnitID, and Type (record type, i.e fault, swing, or the com-
bination of fault and swing).
Record Summary - a report which contains all information 
about a records including Trigger Time, Trigger Event, 
and Comments.

Add Adds records to RecordBase. Browse to select a record.

Delete Removes selected records from the database.

Export Converts records to different file formats such as COM-
TRADE, PTI, and Excel.
D02225R01.54 RecordBase View User Manual 1-3



1 Starting RecordBase View
Send Highlight a record and send to email; it goes as an attach-
ment.
Send multiple records by highlighting more than one 
record before choosing this option.

Save to Highlight a record, then select this option to save the 
record to folder/disk.

Transfer records.. Use this option to transfer records between two distinct 
database files.
1-4 RecordBase View User Manual  D02225R01.54



1 Starting RecordBase View
Add

Figure 1.4:  Add  Records to RecordBase

Select toolbar button Add to add records to RecordBase. Browse to select a par-
ticular record.

Transfer Records

Figure 1.5:  Transfer Records

Use this option to transfer records between two distinct database files.

Select a valid record. 

Select the Add button. 
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1 Starting RecordBase View
Components of RecordBase View

Record Search The bottom portion of the RecordBase window has controls to determine 
which records are displayed in the list.

Figure 1.6:  Record Search

Name Function

Product Choose the product name of the record from the drop-down list.

Unit ID Limit the record list to a specified set of records.

In the past Indicates how far back the list should go.
For example, if today is Tuesday, January 1, 2001 and you specify 
“All Units in the past 2 years” then the RecordBase View lists all 
records dated between Tuesday, January 1, 1999 to Tuesday, Janu-
ary 1, 2001.

Between Select the time frame of the records to be displayed.

Search Button Search and update the record list.
The search specification is remembered so that the next time you 
start RecordBase, the last-used search is automatically run and the 
record list reflects the results.

Clear Button  Clear all records from the record list.

Exit Close.
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1 Starting RecordBase View
Record Sort

Figure 1.7:  Sort by Trigger Time

By default the record list is sorted by Trigger Time, and then by Unit ID which 
emphasizes when the records occurred. Click the column title to sort the list.

Record Summary 
Information

The right side of the screen displays information about the selected record.

Figure 1.8:  Record Summary

Name Function

Trigger Time Select Trigger Time to sort the list by date beginning with the most 
toggle the sort order by date.

Unit ID Select the Unit ID to sort the records by Unit ID and then by Trigger 
Time, emphasizing where the records are from.

Type Indicates whether the record contains high-speed transient fault 
data, low speed dynamic swing data or both.

Click column heading
 to sort.

When a record is 

highlighted on the 

LHS, the RHS 

displays related 

record information

Select the record you 

wish to display 

information.
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1 Starting RecordBase View
If multiple records are selected, summary information is unavailable.

Use the up and down cursor keys to move through 
the list to select a record. Information about the 
record highlighted is displayed on the RHS. 

Name Function

Record Name Associate a descriptive name with a record. You can edit this text. 
The text must conform a valid file name (alphanumeric characters, 
dot ‘.’, underscore ‘_’, minus sign ‘-‘, and spaces).

Trigger Time, Start 
Time, Stop Time

Show the time of the record’s first trigger and the time period of data 
covered by the record.

Unit ID, Station Name Identify the source of the record — read-only fields. The values 
come from the Unit ID and Station Name settings in the unit.

Serial Number, 
Product

Identifies the unit.

Active Group/Setting 
Group

Indicates group used at the time the record was created. This is only 
visible for records with multiple setting groups.

Trigger Event and 
Event List

Portion of the unit’s Event Log that occurred during the recorded 
time period. 
The event list shows the unit’s detector activity such as external dig-
ital input state changes and internal analog detector pickups.

User Comments Editable text field to store comments about the record.
These comments are associated with the record and are always dis-
played with it. The comment field is large (up to 64k). 
Standard Windows cut and paste functions can be used with the 
Comments field. (Ctrl + V for paste, Ctrl + C for copy, Ctrl + X for 
cut.)
1-8 RecordBase View User Manual  D02225R01.54



1 Starting RecordBase View
View Settings View Settings opens Offliner Settings directly from RecordBase View.

Figure 1.9:  View Settings from RecordBase View

The appropriate Offliner has to be installed to view settings.

View Settings - opens

T-PRO Offliner Settings

in settings Summary

window.
F-PRO Offliner Settings 

- Settings Summary

F-PRO Record
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1 Starting RecordBase View
Setting Summary In RecordBase View, select record and the View Setting button to display the 
Setting Summary in Offliner.

If the record contains Setting Groups, the Offliner displays all Setting Groups 
in the summary. Bold text in the tree view indicates an active Setting Group 
(the Setting Group used at the time the record was captured). The setting sum-
mary is read-only. To edit the setting file associated with the summary, you 
must use File/Save As to save the summary to a file. Then close the summary 
screen and open the setting file for editing.

Figure 1.10:  View Setting Summary in RecordBase View

Save Settings Save Settings extracts the relay settings from the record.

Figure 1.11:  Save Settings from RecordBase View

Note: TESLA configuration files can also be stored in this manner.

Save Settings - opens

Save As window to 

choose save location. Choose location to

Save As.

F-PRO Record
1-10 RecordBase View User Manual  D02225R01.54



1 Starting RecordBase View
Reports There are two reports available in RecordBase View: 

   •  Record List

   •  Record Summary

Access reports through the Reports menu item near the top of the window.

Figure 1.12:  Record List Drop Down Menu

Record List 

Figure 1.13:  Record List

A list of the records found by the current search organized like the record list 
in the main display window, but contains the Record Name field for reference.

Record Summary

Figure 1.14:  Record Summary

A report of all the information about a single record, including the event list 
and comments.
D02225R01.54 RecordBase View User Manual 1-11



1 Starting RecordBase View
To produce summary reports on multiple records:

1   Select multiple records from the record list (i.e. highlight the records you 
wish to create a report for).

2   Click on Reports button and select Record Summary.

The resulting report consists of multiple pages, one for each record. Use the 
page control at the bottom of the report to display each page.

Figure 1.15:  Record Summary

To print a Report

1   Generate the report to be printed (using one of the above methods).

2   Select File>Print

The computer must have a default printer defined for the reports to 
be generated. Refer to your Windows Help for details.

Result: 

Record Summary

is generated.
Page control to view 

pages.

Step 1: Select desired 

record to be 

summarized.

Step 2: Select Record 

Summary.
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1 Starting RecordBase View
Viewing Records from Windows Explorer
Use Windows Explorer to add records to RecordBase View database or to view 
the records graphically without adding them to the database.

1   Start Windows Explorer.

2   Locate the desired record and select them. Multiple records can be selected 
using the standard Windows Ctrl or Shift keys in conjunction with the left 
mouse button.

3   Use the right mouse button to bring up the context menu.

4   Select the RecordBase View menu item to activate the sub menu.

Figure 1.16:  Add Record with Windows Explorer

Add Record Adds the selected record(s) to the RecordBase View database. Note 
that you can control how records are added, “Add” on page . 

Launch Graph Brings up the graphics display with the selected record(s).

Export Launches the export utility to convert the selected record to formats 
such as COMTRADE.

The context menu is shown only for valid record types with the follow-
ing extensions: *.lpr, *.lpl, *.lpe, *.tpr, *.tpt, *.tlr, *.bpr, *.bpl, *.fpr, *.fpe, 
*.fpt.
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2 Graphing Records

Getting Started
RecordGraph is a tool that is used to display and analyse records from 
NxtPhase relays and recorders. Use it to graphically view the data recorded 
during fault, swing and trend modes. RecordGraph can be launched from 
RecordBase View software.

 RecordGraph 
Components

   •  Main menu items

   •  Tool bar buttons

   •  A drop-down box lists the templates associated with the current record’s 
IED

   •  A left-hand side pane (LHS) or tree view lists the names of records to be 
displayed or analysed

   •  A right-hand side pane (RHS) displays the graphs in various views. Initially 
a single blank screen appears.

   •  A right-click context menu on both the LHS and RHS pane.

   •  RecordGraph version is displayed in the Help>About RecordGraph.

Figure 2.17:  Components of RecordGraph Window

LHS pane 

(Tree View) 

lists records

RHS Pane shows graphic display

Template List

Tool Bar

Main Menu
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2 Graphing Records
Menus

Figure 2.18:  Menus

Set Graphs Per Page
Add Analog Graph
Add Digital Graph
Delete Graph
Move
Copy Trace
Paste Trace
Delete All Traces
Copy Trace Data to 
  Clipboard
Change Trace Color...
Active Trace Information...

Save Template
Save Template As...
Template Manager...
Print...
Print Direct
Print All
Print Preview...
Export...
Delete
Show Record Summary.
Import...
Exit

p
File     View     Graph     Measure     Scale     Options     Help

File

View

Add...
Delete
Rename Tab
Titles...
Copy to Clipboard
Save as Metafile...
Show Channel List
Line
Toolbar

Graph

Measure
Markers
CrossHairs
Primary
Secondary
Time Alignment
Absolute Time
Fundamental RMS
True RMS
Harmonics
Symmetrical Components

Scale

Zoom X Axis +
Zoom X Axis -
Zoom Y Axis +
Zoom Y Axis -
Undo Zoom
Reset Zoom
Change Scale (Y-Axis)

Help

User Manual
About RecordGraph...
Show Hotkeys...

Options

Calculate Derived Channels Now...
Show Grid
Show X Axis Ticks
Show Legends
Show Trigger Markers
Lock Markers
Extend Print Range
Set Phase Colors...
Set Phase Rotation
Set Precision
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2 Graphing Records
RecordGraph Menu Items

File Menus File>Save Template

Figure 2.19:  Save Template

Use this option to save the current graphical layout information to a file (see 
“Templates” on page 2-57 for further explanations on templates and their role 
in graphical analysis).

When this option is chosen and if there are no templates in the template list, 
then a Save As Template dialog box is displayed. Otherwise, the current layout 
information is saved in a file as shown in the template list box.

File>Save Template As…

Figure 2.20:  Save Template As

Save the current graphical layout information in a different file. A dialog box 
is displayed to choose the template file name. The check box, save as default 
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2 Graphing Records
template, if checked, saves the current template as a user-defined default tem-
plate (for more explanation see “Templates” on page 2-57).

File>Template Manager

Figure 2.21:  Template Manager

Rename, duplicate, save as, import or delete template files. A dialog box is dis-
played to manage the template files (for more explanation see “Templates” on 
page 2-57).

File>Print

Figure 2.22:  Print

Print the active (visible) view. Use this option to select the type of the printer 
and other configurations associated with it through the standard print dialog 
box options.
2-4 RecordBase View User Manual D02225R01.54



2 Graphing Records
File>Print Direct

Figure 2.23:  Print Direct

Send the active view directly to the default printer. When this option is chosen, 
the standard print dialog box is not displayed. The active view is sent directly 
to the default printer for printing, but you can cancel the printing if the print 
status dialog box is displayed.

File>Print All

Figure 2.24:  Print All

Send all the pages of all the views to the default printer. Select this option to 
print multiple views (visible and invisible) to the default printer. 

Multiple Views
D02225R01.54 RecordBase View User Manual 2-5



2 Graphing Records
File>Print Preview

Figure 2.25:  Print Preview

Display the print preview window of the active view page.

File>Export

Figure 2.26:  Export

Export the selected record to a user-defined format, for more details see 
“Record Export” on page 3-1.

File>Delete

Delete the currently selected record from the tree view. This option does not 
clear the view associated with the record.
2-6 RecordBase View User Manual D02225R01.54



2 Graphing Records
File>Show Record Summary

Figure 2.27:  Show Record Summary

Display the record summary and the event list of the active record in a dialog 
box.

File>Import

Figure 2.28:  Import

Choose this option to import a COMTRADE file and display a standard open 
file dialog box to select *.cfg COMTRADE files.

File>Exit

Exit the RecordGraph application. Save your graphical layout information be-
fore selecting this option.
D02225R01.54 RecordBase View User Manual 2-7



2 Graphing Records
View Menus View>Add

Create a new view and add it to the existing layout, for more details refer to 
“Views” on page 2-30.

View>Delete

Figure 2.29:  Delete

Delete an active view from the layout. When you select this option, a dialog 
box appears to confirm the deletion of the view. If accepted, the current view 
is deleted from the layout.

View>Rename Tab

Figure 2.30:  Rename Tab

Replaces the name on the active view tab with one of your choice. A dialog box 
appears to enter the name.

Renames this tab
2-8 RecordBase View User Manual D02225R01.54



2 Graphing Records
View>Titles

Figure 2.31:  Titles

Select graph and view titles options to compile titles and various options, for 
more details refer to “View and Graph Titles” on page 2-63.

View>Copy to Clipboard

Copy an active view to the clipboard for import to another program such as MS 
Word or Excel, for more details see “Record Export” on page 3-1.

View>Save As Metafile

Save an active view page as a Windows metafile, for more details see “Record 
Export” on page 3-1.
D02225R01.54 RecordBase View User Manual 2-9



2 Graphing Records
View>Show Channel List

Figure 2.32:  Show Channel List

Hide or show the channel list displayed in the tree view.

View>Line

Figure 2.33:  Line

Place a reference line on the graph (for Impedance and Differential views 
only). Use Line in conjunction with the CrossHair measurement for quick 
readouts. When you choose this option free form zooming is disabled. Clear 
the line to enable free form zooming.

View>Tool Bar

Show or hide tool bar from the main window.
2-10 RecordBase View User Manual D02225R01.54



2 Graphing Records
Graph Menus Graph>Set Graphs Per Page

Figure 2.34:  Set Graphs Per Page

Set up the number of graphs per view; up to eight graphs are allowed using the 
Set Graphs Per Page option. Timeline, Overlay and Trend Views allow a max-
imum of 36 graphs. Use Add Analog Graph or the Insert key to add one graph 
at a time.

Graph>Add Analog Graph

Figure 2.35:  Add Analog Graph

Add an analog graph to the existing view or use the Insert key.
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2 Graphing Records
Graph>Add Digital Graph

Figure 2.36:  Add Digital Graph

Add a digital graph to the existing view. This graph shows the digital status in-
formation in the form of thick or thin stacked traces. You can plot up to 32 trac-
es in a single graph.

Graph>Delete Graph

Figure 2.37:  Delete Graph

Delete an active graph (click any graph to make it active) from the existing 
view or use the Delete key.
2-12 RecordBase View User Manual D02225R01.54



2 Graphing Records
Graph>Move

Figure 2.38:  Move

Rearrange the relative position of the graphs in the active view page. First se-
lect the graph and use either the Move>Up or Move>Down option to change 
the position of the graph. 

Graph>Copy Trace

Figure 2.39:  Copy Trace

Copy an active trace from the selected graph. Use this option in conjunction 
with the paste trace option. You need at least one channel on a graph to use the 
copy operation.

Copies this trace
D02225R01.54 RecordBase View User Manual 2-13



2 Graphing Records
Graph>Paste Trace

Figure 2.40:  Paste Trace

Add or replace an existing trace in the selected graph. In Timeline View an an-
alog graph supports one trace per graph. In an Overlay View you can select up 
to 32 traces per graph. If you use the paste operation in Timeline View, and if 
the graph has a trace, it is replaced with the one just copied or adds the trace if 
there is no trace. In Overlay View it adds the trace to the existing graph.

Graph>Delete Trace

Figure 2.41:  Delete Trace

Select a graph and the trace to be deleted and use Delete Trace to delete from 
the active graph. In the case of Overlay View a graph can have multiple traces. 
You can select a trace by clicking on the channel name and use delete trace op-
tion to delete the selected trace. 

Trace copied

Trace pasted

Delete Trace removes 
this trace from the graph
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2 Graphing Records
Graph>Delete All Traces

Figure 2.42:  Delete All Traces

Deletes all the traces from the active graph. In an Overlay view this action re-
moves all the traces.

Graph>Copy Trace Data to Clipboard

Copy trace data from the active graph to the clipboard, for further explanation 
see “Exporting Channel Data” on page 2-74.

Graph>Change Trace Color

Figure 2.43:  Change Trace Color

Change the trace color of the selected trace. In the Overlay View this option 
only changes the color of the active trace.

All traces are removed 
from the graph

Color of this trace is changed
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2 Graphing Records
Graph>Active Trace Information

Figure 2.44:  Active Trace Information

Display the trace information of the active graph.

Measure Menus Measure>Markers

Figure 2.45:  Markers

Set or clear markers X and O on all graphs in the active view. If the markers 
are out of range, double-click the time axis to bring them back into the view. 
When markers are placed, depending on the type of measurements option, 
readouts appear on the right hand side as shown corresponding to the positions 
of X and O marker. In case of multiple traces, the readout refers to the currently 
active (selected) trace. 

Amplitude readouts 
corresponding to X & O

Time display corresponding 
to X & O
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2 Graphing Records
Measure>CrossHair

Figure 2.46:  CrossHair

Set or clear crosshair cursor measurement by dragging the mouse (left-click 
and move) anywhere on the graph to display the readout. The difference be-
tween the marker and crosshair readout is that the marker values correspond to 
the data values, whereas the crosshair measurement corresponds to the x and y 
coordinates. When this option is selected, you can measure coordinates of any 
graph in the active view.

Measure>Primary

Figure 2.47:  Primary

Set scale to primary values (depending on the scale factors CT/PT ratios) on all 
the graphs in the currently active view. The current choice (primary or second-
ary) is displayed on the status bar.

CrossHair 
measurements

Primary Scale
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2 Graphing Records
Measure>Secondary

Figure 2.48:  Secondary

Set scale to secondary values (depending on the scale factor of CT/PT ratios) 
on all the graphs in the currently active view. The current choice (primary or 
secondary) is displayed on the status bar.

Measure>Time Alignment

Offset X axis (trigger time alignment) for the currently active trace on the 
graph, for more explanation see “Readouts and Measurements” on page 2-65.

Measure>Absolute Time

Display absolute time (actual recorded time) measurements for the active trace 
of the graph, for more explanation see “Readouts and Measurements” on 
page 2-65.

Measure>Fundamental RMS

Display fundamental RMS measurement for the active trace of the graph, for 
more explanation see “Readouts and Measurements” on page 2-65.

Measure>True RMS

Display true RMS measurement for the active trace of the graph, for more ex-
planation see “Readouts and Measurements” on page 2-65.

Measure>Harmonics

Display harmonics measurement – up to 5th order and THD expressed in per-
cent with reference to the fundamental (up to 25 harmonics depending on the 
sample rate) for the active trace of the graph, for more explanation see “Read-
outs and Measurements” on page 2-65.

Measure>Symmetrical Components

Display symmetrical components measurement for the active graph.You must 
select a, b and c phase quantities in Overlay View to enable this option, for 
more explanation see “Readouts and Measurements” on page 2-65.

Secondary Scale
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2 Graphing Records
Scale Menus Scale>Zoom X Axis +

Figure 2.49:  Zoom X Axis +

Select this option to decrease the x axis range by 25% of the current zoom 
range.

Scale>Zoom X Axis -

Figure 2.50:  Zoom X Axis -

Select this option to decrease the x axis range by 25% of the current zoom 
range.
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2 Graphing Records
Scale>Zoom Y Axis +

Figure 2.51:  Zoom Y Axis +

Select this option to decrease the y axis range by 25% of the current zoom 
range.

Scale>Zoom Y Axis -

Figure 2.52:  Zoom Y Axis -

Select this option to increase the y axis range by 25% of the current zoom 
range.
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2 Graphing Records
Scale>Undo Zoom

Figure 2.53:  Undo Zoom

Display the previous zoom level.

Scale>Reset Zoom

Figure 2.54:  Reset Zoom

Reset the graphs to the initial zoom level.

Reset zoom levels
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2 Graphing Records
Scale>Change Scale (Y axis)

Figure 2.55:  Change Scale (Y axis)

Change Y axis to a desired minimum and maximum value using the dialog box 
to set the new values. If the manual scale option is checked, the y axis is not 
rescaled to new data values; the trace is displayed within the selected range. 
You can set the desired scaling, save the options in the template and recall the 
template for other recordings, for further explanation refer “Templates” on 
page 2-57.
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2 Graphing Records
Options Menus Options>Calculate Derived Channels Now

Use this option to calculate the derived channels and append to the record as 
virtual channels. For TESLA records the data is written back to the original 
record so that the next time the record is viewed all the derived channel infor-
mation is readily available, for further explanation see “Calculated Channels” 
on page 2-72.

Options>Show Grid

Figure 2.56:  Show Grid

Turn grid on or off on all graphs.

Options>Show X Axis Ticks

Figure 2.57:  Show X Axis Ticks

Show X axis ticks on all graphs.
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2 Graphing Records
Options>Show Legends

Figure 2.58:  Show Legends

Show or hide legends on all the graphs.

Options>Show Trigger Marker

Figure 2.59:  Show Trigger Marker

Show or hide trigger marker on the active graph and active curve.
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2 Graphing Records
Options>Lock Markers

Figure 2.60:  Lock Markers

Lock or unlock X and O markers.

Options>Extend Print Range

Figure 2.61:  Extend Print Range

Print all the channels of the view for the entire data range in the current zoom 
level.

X and O markers 
are locked

Entire data is printed in multiple 
pages at the current zoom level
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2 Graphing Records
Options>Set Phase Colors

Figure 2.62:  Set Phase Colors

Use this option to select user-defined colors for A, B and C phase voltages and 
currents. When the colors are selected, the channels are automatically identi-
fied based on the color. The default values for A, B and C phase quantities are 
red, blue and green respectively.

Options>Set Phase Rotation

Figure 2.63:  Set Phase Rotation

Use this option to select ABC or ACB phase rotation. Note that this is used in 
Symetrical Component View.
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2 Graphing Records
Options>Set Precision

Set the precision (number of decimal places) for the readouts. In Symmetrical 
Component and Harmonic Views, the phase angle readout precision is always 
zero (no decimal places are used).

These readouts have 
4 decimal places
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Help Menus Help>User Manual

Select to display an electronic version of the user manual.

Help>About RecordGraph

Display program information, version number and copyright.

Help>Show Hot Keys

Lists the available hot keys or short cuts.

Tool Bar Buttons

Figure 2.64:  Tool Bar Buttons

In the Tree View, you can expand a loaded record to identify the recorded and 
calculated channels (if configured). A right-click menu is available to manip-
ulate the tree items. Most of the tool bar buttons work in a similar way to that 
of the menu items explained in the previous sections.

RecordGraph

File View Graph Measure Scale Options Help

<Default>

Save Template

Show Record Summary

Export...

Print

Add a View

Titles

Add Digital Graph

Add Analog Graph

Set Graphs Per Page

Show/Hide Trigger Marker

Markers

Move Graph Down

Move Graph Up

Zoom X Axis +

Zoom X Axis -

Time Alignment

Zoom Y Axis +

Zoom Y Axis -

Reset Zoom

Show/Hide Legends 

Trace Information

Show/Hide Tree View (Channel List)

Paste Trace

Copy Trace

Change Scale (Y-Axis)

Increase Left Margin

Decrease Left Margin

Line

CrossHair

Relay Data and Impedance Options

Delete Graph

Tool Bar Buttons

Save Template Save template file on the disk.

Show Record Summary Displays record summary (events, trigger time, 
etc.)

Export Brings up export module.
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2 Graphing Records
Print Prints record.

Add a View Adds a graph view that displays the fault infor-
mation.

Titles Places a title above graph for all views, “View 
Title Options” on page 2-64.

Impedance Creates an R-X plot before, during and after 
fault.

Markers Displays vertical lines "x" and "o" to find the 
coordinate values on the graph.

Show/Hide Trigger Marker Displays/hides zero trigger marker.

Set Graphs Per Page Sets number of graphs per page.

Add Analog Graph Add an analog graph.

Add Digital Graph Add a digital graph.

Delete Delete a graph.

Zoom X Axis + Enlarges the trace range on X axis.

Zoom X Axis - Reduces the trace range on X axis.

Zoom Y Axis + Enlarges the trace range on Y axis.

Zoom Y Axis - Reduces the trace range on Y axis.

Reset Zoom Resets zoom control.

Move Graph Up Vertically moves graph upwards.

Move Graph Down Vertically moves graph downwards.

Time Alignment Offset X axis time value. 

Change Scale (Y Axis) Scale Y axis minimum and maximum range.

CrossHair Displays X and Y coordinate values.

Line Available only for impedance view, draws a ref-
erence line.

Copy Trace Copies a trace to another location.

Paste Trace Pastes a trace.

Show/Hide Legends Displays/hides legends the traces. 

Trace Information Displays/hides channel information: Date, Sta-
tion Name, RecordName, Channel Name.

Show/Hide Tree View 
Channel List

Expands and minimizes RHS of the screen.

Decrease Left Margin Decreases left margin.

Decrease Right Margin Decreases right margin.
D02225R01.54 RecordBase View User Manual 2-29



2 Graphing Records
Views 
The view screen graphically displays information from the record. A view is 
associated with a tab at the bottom of the screen which can be renamed using 
the Rename tab. You can create a maximum of 15 view tabs.

 Add a View Add new view to layout.

1   Select the View>Add... from the top menu bar or the Add... button from the 
tool bar.

2   Select the desired view from the pop-up dialogue box.

3   Click OK.

Figure 2.65:  Add a View

Delete a View Clears active view from layout.

1   Select the View>Delete from top menu bar. A pop-up window asks you to 
confirm the deletion. 

2   Click OK to confirm. Click Cancel to stop deletion.

The Add View… option lists Impedance View only if the selected 
record is from an L-PRO, TESLA or COMTRADE record.

Select View>Add... or 

click the Add button 

to create a view type.

Select desired view 

and select OK.

View Tabs
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2 Graphing Records
Rename a View Use this option to rename the active tab which is displayed at the bottom of the 
view.

1   Select the View>Rename Tab from top menu bar or right-click on the graph 
to bring up the context menu and select Rename Tab.

2   A dialogue box appears with the old name. Modify and click OK to rename 
the view.

Figure 2.66:  Rename Dialogue Box

Show Channel List Displays or hides the channel list on the left-hand side of the screen to allow 
more space for the graphs.

Toolbar Displays or hides the toolbar on the left-hand side of the screen to allow more 
space for the graphs.
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2 Graphing Records
Graphs
The graph is an area or space in a view where each channel of analog or digital 
information is shown. The information is shown as X-Y data with X = time and 
Y = magnitude. 

Adding Graphs 1   Select Graph>Set Graphs Per Page or right-click on the graph to bring up 
the context menu and select Set Graphs Per Page to add selected number 
of graphs to the Timeline View.

2   Select Graph>Add Analog Graph or right-click on the graph to bring up the 
context menu and select Add Analog Graph to add an analog graph to the 
Timeline View.

3   Select Graph>Add Digital Graph or right-click on the graph to bring up the 
context menu and select Add Digital Graph to add an digital graph to the 
Timeline View.

A maximum of 36 graphs (analog and digital) can be created for each Timeline 
View, Overlay View and Trend View.

Adding Channels 1   Click the desired channel to be displayed on the graph.

OR

2   Drag a channel and drop it onto the desired graph.

3   Depending on the view type following action takes place:

   •  In a Timeline View the existing channel is replaced and only one chan-
nel is allowed per graph.

   •  In an Overlay View up to 32 traces can be placed per graph.

   •  In a Trend View the existing channel is replaced and only one channel 
is allowed per graph.

   •  External or digital channel should be placed on a digital graph to stack 
the traces. A maximum of 32 traces can be specified per graph.

Channel Tool-tip When the cursor is moved over the channel name, following information is dis-
played in the tool-tip window.

   •  Device – name of the device (example, TESLA)

   •  Record – name of the record

   •  Max – channel maximum value along with the unit 

   •  Min – channel minimum value along with the unit

   •  X – Offset-whether the x-axis has offset (time alignment)

   •  Samples – number of samples 

   •  Sample rate –samples /second (for trend channels it is seconds per sample)

   •  IRIG-B status indicator
2-32 RecordBase View User Manual D02225R01.54



2 Graphing Records
Figure 2.67:  Tool-tip

Zoom Using the 
Mouse

1   Left-click on any graph and drag to form a small box around the graph area.

2   When you release the mouse, the trace assumes new zoom position deter-
mined by the area of the zoom coordinates. 

Figure 2.68:  Select a Section of the Graph to Zoom

Tool-tip window

Drag a box around the 

graph area to be 

zoomed.
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2 Graphing Records
Figure 2.69:  Portion of Zoomed Graph

Follow the procedure 1 and 2 for further zooming.

Zoom Using the Tool 
Buttons

You can also use Zoom X axis +, Zoom X axis -, Zoom Y axis + and Zoom Y 
axis - on the tool bar buttons to quick zoom in and zoom out (25%).

Repeat step 1 to zoom further.

Zoom only X or Y 
Axis

To zoom only the X axis, select Ctrl key and use the mouse to draw a box on 
the graph.

To zoom only the Y axis, select shift key down and use mouse to draw a box 
on the graph.

Undo Zoom on 
Graphs

1   Right-click on the graph to the context menu.

2   Select the UndoZoom option.

3   Graphs are redrawn to the previous zoom level.

4   Select Reset Zoom option to reset the graphs to the initial zoom level. This 
can be chosen at any stage.
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Pan Graph Zoom the graph (if not zoomed) to a required zoom level.

You should hold the “Thumb track” and move it along the scroll bar. To have 
fine control click on the right arrow scroll bar button or press Ctrl and click on 
the right arrow scroll button.

Figure 2.70:  Thumb Track

Keyboard Functions The keyboard is also available for zooming, setting markers and positioning 
graphs. To display the keyboard hot key menu right-click on the graph and 
bring up the context menu, select Show Hotkeys option.

Figure 2.71:  Hot Keys

Thumb Track - move right/left to pan graph
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2 Graphing Records
Right-click Context 
Menu

Figure 2.72:  Right-click Context Menu
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2 Graphing Records
Timeline View

Figure 2.73:  Timeline View

   •  Timeline View is designed to “stack” channels and has single time line axis 
common for all the graphs. 

   •  Each analog graph in this view can hold only one trace. 

   •  Each digital graph in this view can hold 32 traces (8 traces are preferred). 

   •  Selecting a channel from the LHS tree view while the same graph is active 
replaces the existing channel with the currently selected one. 

   •  A maximum of 32 graphs (analog and digital) can be added per view. 

   •  You can mix and match channels from different records and/or IEDs. 

   •  Time line view displays read-out (if markers are on) on the RHS and chan-
nel information on its LHS. 

   •  Read-out corresponds to the currently selected channel type and the scale 
(primary/secondary) which is displayed on the status bar. 

Channel Information

Tool Tip

Record Information

Read-out Markers
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Overlay View

Figure 2.74:  Overlay View

   •  Overlay View is designed to “overlay” channels and has single time line 
common axis for all the graphs. 

   •  Each analog graph in a overlay view can hold 32 traces. 

   •  Each digital graph in this view can hold 32 traces (8 traces are preferred). 

   •  Selecting a channel from the LHS tree view while the same graph is active 
overlays the channel on the selected graph. 

   •  A maximum of 32 graphs can be added per view. 

   •  You can mix and match channels from different records and/or IEDs. Time 
line view displays read-out (if markers are on) on the RHS and channel in-
formation on its LHS. 

   •  Read-out corresponds to the currently selected channel type and the scale 
(primary/secondary) which is displayed on the status bar. 

Channel Information
Record Information
2-38 RecordBase View User Manual D02225R01.54



2 Graphing Records

s

t

Symcom View

Figure 2.75:  Symcom View

   •  Symcom View is designed to analyse symmetrical components of voltage 
or current channels.

   •  You must load 3 voltage or current channels to view the components and 
associated phasor plots from the same record.

   •  The view displays: analog channels, positive, negative, zero sequence 
phasors and corresponding table which contains numerical values of these 
components and phase angle.

   •  All the components are calculated in RMS values.

   •  Channel instantaneous values are displayed on the RHS of the analog 
graph.

   •  Markers are permanently set on the graph one-cycle apart.

   •  Grab the marker and move (on the time line axis) to display new set of com-
ponents and phasor values.

   •  Phase rotaton can be selected by right-clicking and selecting the Set Phase 
Rotation option. Select ABC or ACB.

A, B, C Phase Analog Channel

Phasor and Symmetrical

Component Graph

Diplay of Phases (A, B, C)

Channel Names

Record Title

Markers locked one cycle apar

Time Display

Instantaneous Channel 
Amplitude Display
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2 Graphing Records

rt
Harmonic View

Figure 2.76:  Harmonic View

   •  Harmonic View is designed to analyse harmonics associated with analog 
channels.

   •  A maximum of 3 traces can be analysed per view.

   •  The view displays: analog channels, a bar graph of harmonics and a table 
which contains RMS values of the harmonics with phase angle.

   •  A maximum of 25 harmonics (order) can be displayed.

   •  Channel instantaneous values are displayed on the RHS of the analog 
graph.

   •  Markers are permanently set on the graph one-cycle apart.

   •  Grab the marker and move (on the time line axis) to display a new set of 
harmonics.

All harmonic phase angles are compensated and referenced with re-
spect to "A" phase voltage in relays and a configured channel in TES-
LA recorder. For COMTRADE records phase voltage is the first 
analog channel considered as the reference phase.

Analog Graph

Bar Graph of
Harmonics
Amplitude

Table displays

Harmonic Amplitude

with corresponding 

Phase Angles 

Channel Names

Record Title

Markers locked one cycle apa

Time Display

Instantaneous Channel
Amplitude
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Impedance View Impedance View is an R-X plot. The R-X quantities are calculated over the en-
tire data range from the recorded analog voltage and current channels. R-X plot 
is useful in analyzing the performance of L-PRO relays and swing disturbances 
from the TESLA recorders. Since the information to be displayed involves 
time as a third dimension, this view provides meticulous cursor and zoom con-
trol over the data points being viewed. Optionally it supports superimposition 
of the relay characteristics (Zone 1, Zone 2, Line, Blinders, etc.) from L-PRO 
records or files generated from any L-PRO Offliner settings program. 

The following table summarizes the types of channels from which impedance 
(R and X values) is derived along with the supported product. RecordGraph 
displays these channels on the left hand side in the tree view. Depending on the 
product, the following basic quantities are used the respective impedance chan-
nels.

In impedance calculation, a threshold limit is used based on the fundamental 
RMS value of the current to include or exclude the R and X values for plotting. 
This limit depends on the CT module used for the relay or recorder application. 
For 1A CT module, 0.02 A is the limit whereas for a 5A CT module, 0.1 A is 
used as the limit. When the data is copied to the clipboard, the discarded values 
of R and X values are not exported.

To add an Impedance view select View>Add.. or the Add a View tool bar but-
ton. From the dialog box select Impedance View.

Sl. No. Channel Types Quantities Supported Products

1 High Speed (HS) Voltage and Current B-PRO, L-PRO, 
TESLA, COMTRADE

2 High Speed (HS) Positive Sequence Voltage 
and Current

TESLA

3 Low Speed (LS) Voltage and Current TESLA

4 Low Speed (LS) Watts, Vars and Voltage 
(Phase and Sequence)

B-PRO, L-PRO, 
TESLA

5 Low Speed (LS) Positive Sequence Voltage 
and Current

B-PRO, L-PRO, 
TESLA

6 Low Speed (LS) Impedance (Phase and 
Sequence)

B-PRO, L-PRO, 
TESLA
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2 Graphing Records
Figure 2.77:  View>Add> Impedance

The Add View… dialog box lists the Impedance View only if the se-
lected record is from B-PRO, L-PRO, TESLA or COMTRADE records 
depending on the record type.
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2 Graphing Records
When the Impedance View option is selected, following initial screen is dis-
played.

Figure 2.78:  Opening Impedance Screen

Components and Controls

(1) A text component displays the title at the top of the Impedance View shown 
in Figure 2.78: Opening Impedance Screen. The title is compiled from items in 
the Title Options dialog box. Default title is the file name and trigger event.

(2) The basic channel names are displayed below the title, refer to table “Chan-
nel Types” on page 2-41.

(3) The graph zoom is controlled using the sliding control on the right side of 
the window. The R-X plot aspect ratio is maintained under all zooming tools. 
The graph zoom control offers a 10x zoom factor between minimum and max-
imum amplitude of the data (R and X coordinates). 

(4)The Time Window control provides a means to select the range of data for 
better presentation of R-X values. For example, if the voltage and current chan-
nels are recorded from 0.0 to 0.2 seconds with 1000 data points, using this con-
trol, you can choose to view only 0.1 second data (500 points). 

(5) Time window width and position control can be used for the precise data 
analysis. 

(6) Control the X and O markers.

(1) View Title 

(2) Basic channel names 
and derived impedance type 

(5) Time Window width 
and position control (4) Time Window 

(6) X and O markers 

(3) Graph Zoom control 
(x-y axis zooming) 
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Create Impedance View with an L-PRO Record

1   Launch RecordGraph with an L-PRO high speed (fault) record and expand 
the channels in the tree view. 

2   Create an Impedance View using View>Add… or use the tool bar option.

3   Select line voltages A, B and C, and corresponding line currents A, B and 
C from the tree view. Impedance (R and X) corresponding to Zab, Zbc and 
Zca phase-phase are calculated internally and displayed.

Figure 2.79:  Create Impedance View with an L-PRO Record

Each channel name is divided into three parts:

   •  the basic quantity (voltage or current) used in the calculation of the imped-
ance

   •  the name of the actual channel selected

   •  the resolved impedance name with the configuration (phase-phase or 
phase-ground)

The Time Window control shows the minimum and maximum time of the data 
viewed. In the above example, the full range data is viewed.

Actual channel names 
(as selected from the 
tree view)

Phases of the  basic 
voltage and currents

Resolved impedance 
name

Time Window
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2 Graphing Records
Use the graph zoom control to zoom the x and y axis.

Figure 2.80:  Example of graph zoom control

When you move the mouse near the edge of the Time Window control, the cur-
sor shape changes from normal arrow to two headed arrow as shown in the di-
agram. Now you can resize the thumb track to a desired level of data range. In 
the example, the data starts at position -0.1667 and ends at (-0.1667 + 0.0109), 
where 0.0109 is the width (total data range). Therefore, only small portion of 
the data can be viewed. 

Figure 2.81:  Example of using Time Window control

The thumb track is moved 
from top to the position 
indicated and the traces 
are zoomed in.

Time Window control 
is resized to include 
only portion of the data

Time Window enlarged
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2 Graphing Records
If you move the thumb track (not resize) to the extreme end, then the traces are 
rendered in the new data range.

Figure 2.82:  Time Window control moved to new location

In the above case, the data is included from range -0.0619 to -0.0619 + 0.0109, 
where 0.0109 is the data width. The 0.019 width remains same. If you resize 
the thumb track, then the width can be controlled; or you can double-click near 
the number 0.0109 to get a dialog box to enter the data range precisely.

Figure 2.83:  Indicate data range

A dialog box appears to enter the width or data range, which is indicated by the 
size of the thumb track. The scale indicates the step by which the data is incre-
mental. For example, when the spin control arrow is clicked (after closing the 
dialog box), if an up arrow is clicked, the data is incremental from present po-
sition to present position + 5%. On the other hand, if the down arrow is clicked, 
the data is detrimental by 5%.

Time Window control is 
moved to include 
different range of the data

Time Window enlarged

A dialog box pops-up to enter
the width or data range
indicated by the size of the 
thumb track. The scale
indicates the step by which 
the data is incremented.
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Example to Superimpose the L-PRO Relay Characteristics

Figure 2.84:  Superimpose the L-PRO Relay Characteristics

When you select the Relay data & impedance options button, a dialog box ap-
pears. The parameter required, such as k0 factor, the line sequence impedance 
values, the system voltage data and the other required information is initialized 
through this dialog box initialization. All these values are read from the set-
tings file associated with the record.

Relay data and impedance options

L-PRO settings file Radio button to select relay characteristics from the current 
record. If an L-PRO record is selected, this button is enabled. 

Current record  If a B-PRO, TESLA or COMTRADE record is selected, this but-
ton is enabled.

File Displays the settings file (full path name) from which the relay 
data is extracted to plot the impedance characteristics.

Browse Gives an option to select the settings file from any other location. 
The file type filter reads or selects only *.lps file type, if L-PRO 
setting file is selected..

Impedance Options Impedance configuration option includes a number of other 
options, such as, Phase-Phase, Phase-Neutral, radio button. 
Depending on this option and the type of channel, different 
impedance options (check buttons) are enabled.

Configuration Zpos (positive sequence impedance 3 phase basis)

Zan, Zbn or Zcn

Zab, Zbc, or Zca

Other Impedance

Z-Line Displays the line angle (can be checked or unchecked)

Z-Load Displays the coordinate of the load impedance (can be checked 
or unchecked)

Click this button to 
apply L-PRO relay
characteristics through
the options dialog box
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2 Graphing Records
In the Relay data and impedance options dialog box check the Zone 1 to Zone 
4 boxes and select the Apply button. All the four zone characteristics are super-
imposed on the calculated phase impedances (note that the characteristics are 
zoomed using free-form zoom to get a better resolution).

Figure 2.85:  Example superimposing the zone characteristics

In the above example phase-phase impedances Zab, Zbc and Zca are selected, 
indicated by a check mark, but only Zca is in the zoom range. 

All the four zones mho characteristics are superimposed. You can see that the 
Zca impedance has entered the Zone 2 and Zone 3. You can use a combination 
of zoom and time window control to analyze the precise time at which the im-
pedance enters the zones.

Blinders Available only if the Phase-Phase option is chosen.

Directional

Zones to display Phase-Ground or Phase-Phase

Zone 1 to 4 Zone1-Zone4 displays the respective zones impedance charac-
teristics (can be checked or unchecked)

Apply Redraws the display with the currently selected options.

Launch Launches the setting file through the Offliner settings program. 
Note that the L-PRO Offliner setting program should be installed 
for this to work successfully.

Close Closes the dialog box.

Relay data and impedance options
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2 Graphing Records
Figure 2.86:  Example showing the Line and Blinder impedances

Check the Z-Line and Blinder boxes; then select the Apply button to superim-
pose the line and blinder impedances.

Figure 2.87:  Example illustrating the use of the CrossHair measurement

Select the CrossHair button. When you drag the mouse (left button down and 
move) on any point on the trace, the R, X and the Z corresponding values are 
displayed.

You can move the cursor anywhere on the graph to get the measurement. When 
this feature is enabled, free form zooming is disabled; but you can use the 
graph zoom control to get a closer look at the trace.

Line Impedance

Blinder Impedance

Select this button to 
enable CrossHair 
measurement feature

CrossHair 
measurements
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Figure 2.88:  Example of the Line feature

Set a reference line to measure the data using the Line feature. This line is a 
reference line and not associated with the data values.

When the line option is enabled, the free form box zooming is disabled. Dis-
able the CrossHair measurement to resize and move the reference line; then en-
able the CrossHair option to measure the values.

Figure 2.89:  Example of the legends feature

Use the legend feature to distinguish relay characteristics from the calculated 
impedances. You can move the legend box and resize to the desired level. You 
can hide the legend box by re-selecting the legend option again.

Select this button to 
set an arbitrary line

Arbitrary line for the
reference purpose

Legend feature button

Legend box with all the 
relay characteristics 
impedance names
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2 Graphing Records
Figure 2.90:  Legends features moved and enlarged

Figure 2.91:  Example illustrating the use of data markers

Select the marker option to set the markers. Select the desired channel name 
for the required measurement. For example, the channel associated with Zca is 
chosen (click this channel name for the selection). Move the marker by sliding 
it to the desired location. When you change the data range (using Time Win-
dow control), the cursors may disappear from the traces indicating that the 
markers are always associated with the data.

Resized legend box showing
all the relay characteristics 
impedance names

Cursor corresponding 
to marker O

Marker button

Cursor corresponding 
to marker X

Marker X and O Marker X and O 
readouts

Select channel name
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2 Graphing Records
Figure 2.92:  Example of L-PRO swing record choosing positive sequence voltage and 
current

Select an L-PRO swing record from RecordBase View and expand the chan-
nels. Click the positive sequence voltage and current; RecordGraph automati-
cally calculates and displays the positive sequence impedance.

Figure 2.93:  Example of L-PRO swing record choosing watt, var and positive sequence 
voltage channels

Select an L-PRO swing record from RecordBase View and expand the chan-
nels as shown. Click the watt, var and positive sequence voltage; RecordGraph 
automatically evaluates and displays the positive sequence impedance.

Positive sequence 
impedance trajectory

Positive sequence 
impedance trajectory
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2 Graphing Records
Figure 2.94:  Example of L-PRO swing record choosing impedance channel

Select an L-PRO swing record from RecordBase View and expand the chan-
nels as shown. Click the impedance channel; RecordGraph automatically dis-
plays the positive sequence impedance trajectory.

As you select the desired channels, the impedance (R-X characteristics) are su-
perimposed on the existing relay characteristics. To select new set of voltage 
and current channels use the Delete trace(s) option from the right-click context 
menu and select new channels. If desired, you can modify or re-apply the im-
pedance options.

Drag the thumb track on the scroll bar to zoom in or zoom out the axis range. 
In the Time Window control + click the arrow buttons or drag the thumb track 
to scroll the window of visible data in the time domain.

To place the X and O markers use the tool bar or the right-click context menu 
or the View>Markers option, dragging a marker to the right or left moves cor-
responding marker. If the Time Window control does not show the data, then 
the markers are shown as small triangles on the left or right sides. If you click 
the triangle, corresponding data cursor is displayed and the time range is auto-
matically adjusted.

You can save all the impedance display options to a template file (File> Save t

Positive sequence 
impedance trajectory
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2 Graphing Records
Differential View Differential View displays the variation in operating current, Io and restraint 
current Ir. This view is designed specifically for T-PRO and B-PRO (single 
and 3 phase) relays. This view is designed with intuitive zoom, time range and 
cursor controls similar to that of Impedance View.

Open a record from a T-PRO or a B-PRO relay; then use the View>Add.. but-
ton and choose Differential View.

Figure 2.95:  Add Differential View

When you select the Differential View option, the following screen is present-
ed.

The Add View dialog box is only available if the selected record is 
from T-PRO or B-PRO.
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2 Graphing Records
Figure 2.96:  Differential View

In case of T-PRO and B-PRO 3-phase relays, the differential characteristics 
corresponding to a, b and c phases are displayed, whereas in the case of single 
phase B-PRO, the selected phase differential characteristics are displayed.

Note that in this view, you are not allowed to add/delete traces, but the zoom-
ing, panning, markers and other facilities which are available in the Impedance 
View is also available with this view.

The differential characteristics are only displayed for those devices which are 
enabled. If no devices are enabled, then a blank graph will be displayed.

Channel Names

Record Title

Time Window

Zoom In

Zoom Out
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2 Graphing Records
Trend View

Figure 2.97:   Trend View

   •  Trend View is designed to display “trend” data.

   •  It has a special x-axis, common to all the graphs to display the data in the 
“date” format. When zoomed, the scale automatically changes depending 
on the date range. (For example: years/months or months/days or days/
hours or hours/minutes or minutes/seconds).

   •  Each analog graph in a trend view can display one trace.

   •  A maximum of 32 graphs can be added per view.
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2 Graphing Records
Templates

Figure 2.98:  Template List

Template contains user-defined layout information including:

   •  Views – graphs and their location along with the traces (channels)

   •  Markers position (X, O and trigger marker, T)

   •  Views and graphs title options

   •  X axis scaling (zooming information)

   •  Y axis scaling (zooming information)

   •  X axis shift (time alignment) of each channel

   •  Measurement (readout) options

   •  Left Margin

Template stores the easy-to-manage layout information in a file based on prod-
uct type (B-PRO, F-PRO, L-PRO, T-PRO, TESLA, COMTRADE).

When the template information is stored, it can be applied to any recording 
(normally from same IED or product) for which the template is valid. For ex-
ample, if a template has 3 views with 3 graphs per view, and has 1, 2 and 3 an-
alog channels displayed with various options, this information can be applied 
to any record with that common framework. The concept is to re-use the com-
mon layout information and update the data information with the new recorded 
channels thus reducing the graph re-creation processing time.

These flexible and user-defined templates can be shared among different users. 
Normally (under default installation options), templates are stored on the local 
hard disk in a sub-folder where the RecordGraph application resides, for exam-
ple, c:\Program Files\APT\RecordGraph\template

Templates associated with a record.

Left Margin
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2 Graphing Records
The template graphical layout file contains information about fixed views, 
graphs, traces, marker positions, read-out, scaling and zoom range. You can 
analyse a system disturbance recorded at different times and at different loca-
tions using the template.

When a template is opened, the predefined layout information is automatically 
applied based on the new record (or set of records). You can save time by view-
ing the data recorded without manually loading the traces again. Templates are 
the first step in generating a visual report.

You automatically form a template when you create views and graphs. To re-
apply the template to a different recording from the same or different recorder, 
you must save this layout information in a file. You can extend or alter tem-
plates by manipulating views, graphs and traces.

Templates are not saved automatically, but must be saved using the File>Save 
Template option. Template files can be shared and customized. The list of tem-
plates is dynamically created and displayed in the tool bar. When a record is 
added to RecordGraph, an automatic scan search is done to list the templates 
corresponding to the record loaded. This list may have both single or multi-
record templates, if the record loaded is a part of multi-recorder template. If no 
match is found, a <Default> template is loaded. You can define any number of 
templates based on a single recorder or multiple recorders.

Default Templates Hard coded, static default templates are created whenever you open the Re-
cordGraph application. These are not stored in the file, but are dynamically 
created and displayed as <Default> in the list box.

You can override this <Default> template by saving any other template as a de-
fault template. 

The user-defined default template path is stored in the registry key based on the 
product and the type of recording (applicable for all products).

For example:

   •  TESLA/HS - high speed

   •  TESLA/LS - low speed

   •  TESLA/Trend - slow recordings
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2 Graphing Records
Managing Template 
Files

Whenever a new record file is loaded into the RecordGraph, it automatically 
loads the relevant template file names in a list box attached to the main tool bar. 
The template files are filled or updated based on certain rules:

   •  Templates are stored based on product type.

   •  If a user-defined default template is available, it is loaded as the first item 
in the list box, otherwise, a static <Default> template is listed as the first 
item.

   •  Template files are matched based on IED (serial number) in the case of 
TESLA recorders and are common in case of relay products (B-PRO, F-
PRO, L-PRO, T-PRO.

If template files for a TESLA recorder are created and stored (for example, 
with serial number TESLA-2000-981103-07), these template files can not be 
applied to another recorder with different serial number such as TESLA-2000-
981103-08. On the other hand, if template files are created for relay products 
such as L-PRO, this template can be applied to any relay IED B-PRO, F-PRO, 
L-PRO or T-PRO). Hence, templates are IED-based (serial number-based) in 
case of recorders and product-based in case of relays.

Double-click (or use the Enter key) on the currently active record in the Re-
cordGraph tree list (displayed in bold) to apply the template or pick any desired 
template from the template list box. 

Templates can be renamed, duplicated or deleted using template manager from 
within the RecordGraph.

There is no limitation on the number of template files used (as long as the hard 
disk space is available).

Create New 
Template File

1   Modify the existing template layout information and save the modified tem-
plate into a new file.

2   Create new views and graphs by deleting the views from the existing layout 
and saving new ones into a new the template file.

If the template file is created from multiple records, all the records should be 
pre-loaded into RecordGraph to successfully apply the layout information.

Layout information is applied one at a time. If the template involves more than 
one record, apply template (double-click on each record) to fill respective 
channels. The name of the recorder IED in the template file are displayed in the 
tool-tip list box window when the mouse cursor is moved over it. The tool-tip 
also displays the product name and the user-defined default template file name, 
if one exists.
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2 Graphing Records
Templates Menus Save Template 

Displays a dialogue box only if <Default> template is currently displayed in 
the template list box. Since <Default> template name is reserved for hard cod-
ed templates, you must save the template information with a new name. If any 
other template file name is displayed, other than <Default>, the layout infor-
mation is updated without the dialogue box being displayed.

Save Template As...

Displays a dialogue box to save the template. The option Save as default tem-
plate, if checked, saves the template as user-defined default template. Refer 
previous section for more explanation on the user defined default template.

Template Manager...

Figure 2.99:  Template Manager

Brings up the template manager dialogue box which lists all the templates cur-
rently available.

Rename

Renames the currently selected template. 

Duplicate

Copies the contents of the selected template into another file.

Delete

Deletes currently selected template.
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2 Graphing Records
Template - Tool Tip 

Template tool tip information displays:

   •  IED name

   •  User-defined default template associated with that IED

   •  Serial number of the IED which is used as the unique feature to match the 
templates.

Template - Single 
IED

1   Open a record from the desired IED (B-PRO, F-PRO, L-PRO, T-PRO or 
TESLA).

2   Create or modify the existing layout information.

3   Use Save Template as... option to save the new layout information with a 
desired template name.

Template Tool Tip

A single IED template is saved/matched based on its serial number. 
Any record from the IED with the same serial number can use or 
share the template (layout) information.
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Template - Multiple 
IED

Figure 2.100:  Multiple IEDs

1   Open records from two or more desired IEDs (different TESLAs or different 
relays).

2   Create or modify the existing layout information (create graphs by selecting 
channels from different IEDs).

3   Use Save Template as... option to save the new layout information with a 
desired template name.

When all IED records are pre-loaded into the RecordGraph, multiple 
IED templates are saved/matched based on serial number. If the 
record is loaded one at a time, then double-clicking on each record 
reapplys the template filling the respective channels.
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2 Graphing Records
View and Graph Titles
When a new record is loaded, the information corresponding to the options se-
lected is compiled and the updated information is displayed in the View Title. 

Figure 2.101:  View and Graph Titles

View Title View Title is the title on the top of each record view. When a new record is 
loaded, the information corresponding to the options selected is compiled and 
the updated information is displayed in the View Title. You can choose any of 
four options by clicking the arrows to move the items in the list. The option is 
saved into the template. This option is not available for the Symcom or Har-
monic Views. 

The option choices are:

   •  Record Name

   •  Station Name

   •  Location

   •  Trigger Time

   •  UnitID or Relay

   •  Product Type

   •  Serial Number

   •  Trigger Event

   •  System Frequency

   •  Priority

View Title
GraphTitle
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2 Graphing Records
Figure 2.102:  View Title Options

Graph Title Graph Title is the information that appears on the left margin of each graph. 
Graph Title is a combination of various options. When a new record is loaded, 
the information corresponding to the options selected is compiled and the up-
dated information is displayed in the Graph Title dialogue box. You can choose 
any four options by clicking the arrows to move the items in the list. The option 
is saved into the template. This option is not available for the Overlay View.

The option choices are:

   •  Channel name

   •  Trigger time

   •  Station name

   •  Record name

   •  Location

   •  UnitID or relay

   •  Sample rate

   •  Equipment ID

Figure 2.103:  Graph Title Options
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2 Graphing Records
Readouts and Measurements
The Measure menu consists of the following:

   •  Markers

   •  Primary/Secondary

   •  Time Alignment

   •  Absolute Time

   •  Fundamental RMS

   •  True RMS

   •  Harmonics

   •  Symmetrical Components

Figure 2.104:  Readouts and Measurements

Markers Selecting Measure>Markers or using the tool bar button places the “X” and 
“O” markers on the graph, as well as, automatically placing markers on all new 
graphs. If the markers are out of view range, double-click on the timeline graph 
to bring back the markers to the desired location. Marker positions are saved 
into the template. Readout corresponding to the option chosen is displayed on 
the right side of the graph. Selecting trigger marker, T, displays the trigger time 
of the record.

Primary Selecting Measure>Primary multiplies the channel data by the primary scal-
ing factor and redraws the y-axis for all graphs.

Secondary Selecting Measure>Secondary multiplies the channel data by the secondary 
scaling factor and redraws the y-axis of all graphs.

Fundamental RMS

Time Alignment

Absolute Time

True RMS

Trigger

Harmonics

Markers
D02225R01.54 RecordBase View User Manual 2-65
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Time Alignment Use this option to offset or align the trigger time of channels (normally from 
different locations) or shift the x-axis time. This feature offsets the x-axis time 
data by a precise value as desired.

1   A trace (channel) must first exist on the graph. Click the graph that you want 
to show time alignment.

2   Select the Graph>Time Alignment menu option or the Time Alignment but-
ton on the tool bar.

3   Use the “spin” control (up and down arrows) to increase or decrease the off-
set.

4   Double-click the value to bring up a dialogue box to enter the new offset 
value and offset scale. Offset scale is the percent by which the increment is 
required.

5   Clear this option, by a second click on the Time Alignment button on the tool 
bar or by selecting the Graph>Time Alignment menu option a second time.

Figure 2.105:  Time Alignment

Spin control to quickly
vary the offset value

Time alignment toolbar button

Edit box to change the offset value.
Note: Double-click here to change 
the offset value and the offset 
scale (increment)
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Absolute Time This option displays the absolute time—the actual time of the recorded chan-
nels.

1   A trace (channel) must first exist on the graph. Click the graph that you want 
to show absolute time measurement.

2   Select the Measure>Markers menu option or the Markers button on the tool 
bar to place the markers on the graph. Markers are automatically placed if 
not selected.

3   Select Measure>Absolute Time menu option.

4   Readout corresponding to the markers is displayed on the right-hand side of 
the graph including:

   •  Year, Month, Day of the recording (yyyy/mm/dd)

   •  Absolute Time corresponding to marker X

   •  Absolute Time corresponding to markers O

   •   Difference in the Absolute Time between marker X and marker O

Figure 2.106:  Absolute Time

Absolute Time
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Fundamental RMS This option displays the RMS measurement of the fundamental (60 or 50 Hz) 
between the two markers (X and O) of the selected channel.

1   A trace (channel) must first exist on the graph. Click the graph that you want 
to show absolute time measurement.

2   Select the Measure>Markers menu option or the Markers button on the tool 
bar to place the markers on the graph. Markers are automatically placed if 
not selected.

3   Select Measure>Fundamental RMS menu option.

4   Readout corresponding to the markers is displayed on the right-hand side of 
the graph including:

   •  RMS (fundamental frequency) Title

   •  Minimum RMS

   •  Maximum RMS

   •  Average RMS

Figure 2.107:  Fundamental RMS

Fundamental RMS
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True RMS This option displays true RMS measurement values of all the harmonics (up to 
25 order—including the fundamental), depending on the sample rate of the re-
corded channel. 

1   A trace (channel) must first exist on the graph. Click the graph that you want 
to show absolute time measurement.

2   Select the Measure>Markers menu option or the Markers button on the tool 
bar to place the markers on the graph. Markers are automatically placed if 
not selected.

3   Select Measure>True RMS menu option.

Readout corresponding to the markers is displayed on the right-hand side of the 
graph including:

   •  True RMS Title

   •  Minimum True RMS

   •  Maximum True RMS

   •  Average True RMS

Figure 2.108:  True RMS

True RMS
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Harmonics This option displays the harmonic contents (magnitude) of the desired channel 
along with the Total Harmonic Distortion (THD) in percentage. 

1   A trace (channel) must first exist on the graph. Click the graph that you want 
to show absolute time measurement.

2   Select the Measure>Markers menu option or the Markers button on the tool 
bar to place the markers on the graph. Markers are automatically placed if 
not selected.

3   Select Measure>Harmonics menu option.

4   Readout corresponding to the markers is displayed on the right-hand side of 
the graph including:

   •  Harmonics Title

   •  2nd Harmonic

   •  3rd Harmonic

   •  4th Harmonic

   •  5th Harmonic

   •  THD% of fundamental (up to 25 harmonics) depending on the sample 
rate.

Figure 2.109:  Harmonics

Harmonics
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2 Graphing Records
Symmetrical 
Components

This measurement option displays the magnitudes of the positive, negative and 
zero sequence components of 3-phase voltage or current channel. 

1   Create an Overlay View— you must have a 3-phase voltage or current chan-
nel.

2   Place three phase voltage or current channels on the graph.

3   Select the Measure>Markers menu option or the Markers button on the tool 
bar to place the markers on the graph. Markers are automatically placed if 
not selected.

4   Readout corresponding to the markers is displayed on the right-hand side of 
the graph including:

   •  SymCom Title

   •  Positive sequence component magnitude

   •  Negative sequence magnitude

   •  Zero sequence magnitude

Figure 2.110:  Symmetrical Components

Phase Rotation is automatically determined based on relay setting information, 
or is by default set to ABC; this can be changed by right-clicking on the view 
and selecting "Set Phase Rotation", or from the Options Menu.

Symmetrical Components
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Calculated Channels
Calculated channels are virtual channels derived from the original recorded 
channels. They are calculated based on the configuration information. In the 
TESLA recorder, all the calculated channels are added to the original record 
only once, but are available any time for the view with the RecordGraph appli-
cation. Calculated channels differ widely depending on the product. They are 
classified under high and low speed categories. 

High Speed Calculated channels

   •  Summation

   •  Positive sequence

   •  Negative sequence

   •  Zero sequence

   •  Watts (single and three phase)

Low Speed Calculated channels

   •  Summation

   •  Positive sequence

   •  Watts (single or three phase)

   •  Vars (single or three phase)

   •  Impedance

   •  External

Type and number of channels available for the view depends on the configura-
tion information. 

Choose Options>Calculate Derived Channels Now to add the calculated chan-
nels. If this option is disabled, then the calculated channels are already avail-
able.

Figure 2.111:  Calculated Channels

Calculated Channels
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2 Graphing Records
Exporting Views
Export active visible views to windows standard clipboard or to an enhanced 
metafile. Following options are available:

   •  Copy To ClipBoard

   •  Save As MetaFile

Figure 2.112:  Export Views

Copy to Clipboard Copies view to the clipboard in order to copy into another document, for ex-
ample Microsoft Word.

1   To copy to clipboard select View>Copy to Clipboard or right-click on the 
graph to bring up the context menu and select Copy to Clipboard.

2   Open any other software package, which supports the “pasting” facility 
from the clipboard (for example Excel or Microsoft Word) and paste the 
view.

Save View as 
Metafile

Saves the view to a Metafile format *.emf.

1   To save to as a Metafile select View>Save to Metafile... or right-click on the 
graph to bring up the context menu and select Save to Metafile. 

2   A dialogue box appears prompting you to save the file in a selected folder.

Figure 2.113:  Save to Metafile

Copy to Clipboard

Save to Metafile
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Exporting Channel Data
Any channel data can be exported to the clipboard from the active view. If a 
graph has multiple channels, all the channel data is exported to the clipboard.

This option copies the trace data to the clipboard and using Edit>Paste to paste 
into other applications like Microsoft Word or Excel.

Figure 2.114:  Copy Trace to Clipboard

Pasting exported data using Microsoft Excel

1   Open Microsoft Excel.

2   Choose Edit>Paste Special.

Figure 2.115:  Paste Special using Excel

Pasting exported data using Microsoft Excel

Choose csv (comma separated variable) format and click OK.

Copy Trace Data to Clipboard
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2 Graphing Records
Figure 2.116:  Choose csv

Pasting exported data using Microsoft Excel

Domain: normally time data, it can be date YYYY/mm/dd in case of trend data.

Figure 2.117:  Past to Excel
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Record Summary
1   Click the record name to enable this feature.

2   Choose File>Show Record Summary… to display the record summary.

Figure 2.118:  Show Record Summary

Digital Channel Status Indicator
Highlight digital channel which change state (with different icons), and list 
only configured channels in the tree view. A mimic screen shot of the icons is 
shown below. The <default> template automatically displays the digital chan-
nels which changes the state.

Figure 2.119:  Digital Channel Status Indicator

Icon with changes
in the digital status

Icon with no changes
in the digital status
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2 Graphing Records
 IRIG-B Input Status Display
IRIG-B input status (synchronized, unsynchronized or unknown) is displayed 
in the tool tip window when you place the mouse on the channel name or use 
Active Trace Information.

Figure 2.120:  IRIG-B Input Status Indicator

Derived Digital Swing Channels for TESLA Swing Recordings
TESLA recordings do not record External Input channels for the swing 
records. A facility to view these channels in the RecordGraph is provided. Re-
cordGraph automatically displays these channels (if configured) under low 
speed channel group. Events with the same element are grouped together to 
form a channel. This facility is backward compatible.

Derived Channels for L-PRO, F-PRO High Speed Recordings
For L-PRO and F-PRO high-speed records, Main and Aux individual phase 
summation channels are added to the existing derived summation channels. 
This facility is backward compatible.

Derived Channels for B-PRO, L-PRO Swing Recordings
For B-PRO and L-PRO swing records, real power, reactive power, and imped-
ance channels for the configured inputs are added.

IRIG-B status indicator
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COMTRADE Import
COMTRADE (Common Format for Transient Data Exchange) is an industry 
standard record format used to share data between tools and to replay faults 
through a test set. The import utility supports viewing of both ASCII and bina-
ry COMTRADE formats (1991 and 1999). When the COMTRADE file is im-
ported into the RecordGraph, all its functionality can be seamlessly used to 
analyze the record.

1   RecordGraph application must be running to access this facility. If not, 
launch RecordGraph via TESLA Control Panel, RecordBase View or Win-
dows Explorer.

2   Choose File>Import.

3   Browse to select desired file.

4   Double-click on the COMTRADE record to apply <Default> template or 
select it from the templates list box.

Figure 2.121:  Import COMTRADE File

Import file
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Figure 2.122:  Select COMTRADE File

Figure 2.123:  Apply <Default> Template

Choose COMTRADE File
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Print Options
The following options are available:

   •  Print... – pops-up a print option dialogue box to select paper size, orienta-
tion and other options.

   •  PrintDirect – sends active view directly to the default printer.

   •  PrintAll – sends all the views directly to the default printer.

   •  Print Preview…– displays standard preview window.



3 Record Export

The record export utility lets you convert records into a number of different 
formats for use with other software tools.

COMTRADE

Common Format for Transient Data Exchange is an industry standard record 
format used to share data between tools and to replay faults through a test set. 
The export utility supports both ASCII and binary COMTRADE formats and 
creates output that complies with the latest (1999) or older version (1991) of 
the standard.

PTI

Power Technologies Incorporated produces widely used power system model-
ling tools. Records can be exported in a PTI-compliant format for import into 
PTI tools. The export utility supports ASCII format and creates output that 
complies with PTI version 1 or version 2 formats.

Excel (CSV)

Records can be exported in basic comma separated values (also known as com-
ma-delimited) ASCII format suitable for importing into standard tools such as 
Microsoft Excel.

All quantities are exported in secondary values.
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3 Record Export
Launch the Export Utility
To launch the export utility:

1   Double-click Recordings from the Main Menu.

2   Select a local record from the record list.

3   Select the Export button to launch the Export window.

4   Select the desired export output format and select OK.

Figure 3.1:  Select Export File Type

Step 2: Select a record 

from the list.

Step 3: Click on the

Export button to 

launch export window.

Step 1: Double-click 

Recordings from the 

Main Menu Step 4: Choose export

type and OK.
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3 Record Export
COMTRADE Format

Figure 3.2:  COMTRADE Settings

The COMTRADE format (IEEE C37.111) defines a common format for stor-
ing digital data records of transient and dynamic swing events.

COMTRADE export consists of up to four output files with the same base 
name and different file extensions: configuration files (.cfg), header files 
(.hdr), data files (.dat) and optional information files (.inf). COMTRADE ex-
port produces the configuration, header and data files.

With reference to “COMTRADE Settings” on page 3-3,

Name Function

Export to. The base file name and directory of the output files are set 
using the Export to.. option. 
By default the base filename is the same as the record you are 
exporting. 
You can edit this or use the Browse button to set a new direc-
tory and/or base filename.

Station Name and 
Identification 

The Station Name and Identification fields are set by default 
using the unit’s Station which are written as the first line in 
the.cfg output file. 

Header Text The Header Text field contains the text written into the COM-
TRADE header (.hdr) file. By default, the field contains the 
Location, Name, Number and the Unit ID of the unit that pro-
duced the record. 
This text can be modified, deleted or extended as desired.

Version The Version field lets you select the revision of COMTRADE 
standard to produce. COMTRADE has been an evolving stand-
ard and a number of changes have been made over the years. 
1991 and 1999 COMTRADE versions are supported.

Format The Format field specifies that the data in the COMTRADE file 
(ASCII or BINARY format).
ASCII data has the advantage of being usable by simple text 
editor and spread sheet programs, but results in a significantly 
larger record relative to binary format. 
BINARY format is recommended if the software package you 
are using for the data, supports binary format COMTRADE.
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3 Record Export
Selecting Channels 
(Exported Channels)

You must select the channels from the record that you want to 
include in the output file. 
For convenience, the digital data recorded is classified into:
• High Speed (5760/sec): Analog and external digital input 

channels sampled at the high speed transient data rate.
• High Speed (480/sec): Analog and internal logic channels 

produced 8 times per cycle.
• Low Speed (60/sec): Analog input channels sampled at the 

low speed swing data rate.
Select the desired channel from the list with a left-click. 
Multiple channels can be selected using standard Windows 
selection actions (click + Ctrl or Shift keys).

 Place selected channels in the Exported Channels list box. 

Place all channels into the Exported Channels list box. 

Delete a channel from the Exported Channel list box.

Delete all channels from the Exported Channel list box.

 Offset negative start 
times to begin at zero

When checked, this option shifts the negative time to start from 
zero.

>

>>

<

<<
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3 Record Export
 PTI Format 

Figure 3.3:  PTI Settings

The PTI file format is used to import records into the Power Technologies In-
corporated system modelling software.

Output File PTI export produces a single output file with an .asc extension.

Name Function

Export to.. The base filename and directory of the output files are set 
using the Export to.. option. 
By default the base filename is the same as the record you are 
exporting. 
You can edit this or use the Browse button to set a new direc-
tory and/or base filename.

Station Name and Identifi-
cation

The Station Name field is set by default using the unit’s Station 
Name setting. It is written as the first line after all the channel 
names. This text can not be edited. 
The Identification field is not written to the PTI output file.

Header Text The Header Text field contains the text that is written as a sin-
gle line in the fourth line in the output file. 
By default, the field contains the Location, Name, Number and 
Unit ID of the recorder that produced the record. 
This text can be modified, deleted or extended as desired.

Version The Version field lets you select between PTI version 1 and 
version 2. Please refer to PTI documentation for details on the 
differences of these versions. 
Format Only ASCII format output files are available.

Format ASCII is the only format option for PTI.
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3 Record Export
Channel Selection Use Channel Selection to select channels to export. 
You must select the channels from the record that you want to 
include in the output file. 
For convenience, the digital data recorded is classified into:
• High Speed (5760/sec): Analog and external digital input 

channels sampled at the high speed transient data rate.
• High Speed (480/sec): Analog and internal logic channels 

produced 8 times per cycle.
• Low Speed (60/sec): Analog input channels sampled at the 

low speed swing data rate.
Select the desired channel from the list with a left-click.
Multiple channels can be selected using standard Windows 
selection actions (click + Ctrl or Shift keys).

 Place selected channels in the Exported Channels list box. 

Place all channels into the Exported Channels list box. 

Delete a channel from the Exported Channel list box.

Delete all channels from the Exported Channel list box.

 Offset negative start 
times to begin at zero

When checked, this option shifts the negative time to start from 
zero.
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3 Record Export
Excel (CSV) Format

Figure 3.4:  Excel (CSV) Settings

The Excel CSV (Comma Separated Value) format is used to import records 
into a Microsoft Excel spreadsheet. This format is also known as comma de-
limited ASCII and can generally be used by most programs that import data ar-
rays.

Excel CSV export produces a single output file with a .csv extension, which is 
recognized by Excel. Excel is automatically launched when you double-click 
on file. 

Name Function

Export to.. The base filename and directory of the output files are set 
using the Export to.. option. 
By default the base filename is the same as the record you are 
exporting. 
You can edit this or use the Browse button to set a new direc-
tory and/or base filename.

Station Name and Unit ID The Station Name and Identification fields are not written to the 
Excel CSV format output file. 

Header Text There is no header text written to the Excel CSV format output 
file.

Version There are no version options for the Excel CSV output.

Format ASCII is the only format options for the Excel CSV output.
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3 Record Export
Exporting T-PRO 
Through Fault 
Events in Excel 
(CSV) Format

Through fault event files (*.tpe) can be exported using Excel (CSV) format.

   •  1.  Open RecordBase View application and select a T-PRO event file as 
shown below (if the event file does not exist in the database, you can sim-
ply click on the "Add" button and select T-PRO event file to add it to the 
existing database).

Figure 3.5:  RecordBase View main window with T-PRO Event records

Channel Selection You must select the channels from the record that you want to 
include in the output file. 
For convenience, the digital data recorded is classified into:
• High Speed (5760/sec): Analog and external digital input 

channels sampled at the high speed transient data rate.
• High Speed (480/sec): Analog and internal logic channels 

produced 8 times per cycle.
• Low Speed (60/sec): Analog input channels sampled at the 

low speed swing data rate.
Select the desired channel from the list with a left-click. Multiple 
channels can be selected using standard Windows selection 
actions (click + Ctrl or Shift keys).

 Place selected channels in the Exported Channels list box. 

Place all channels into the Exported Channels list box. 

Delete a channel from the Exported Channel list box.

Delete all channels from the Exported Channel list box.

 Offset negative start 
times to begin at zero

When checked, this option shifts the negative time to start from 
zero.

>

>>

<

<<
3-8 RecordBase View User Manual  D02225R01.54



3 Record Export
   •  2.  Click on "Export" toolbar button which displays "Select export file type" 
dialog and select Excel (CSV) file type.

Figure 3.6:  Export file type selection Excel (CSV) format

   •  3.  Once you select Excel (CSV) file export type, the following dialog will 
be displayed to select the file name. Choose the desired location and file 
name and click OK to export the event data.

Figure 3.7:  File and Location selection through CSV Export settings

   •  4.  Double click on the exported Excel (CSV) file to view the events ar-
ranged in descending order.  A typical example of the csv file is depicted 
below.
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3 Record Export
Figure 3.8:  Example of converted through fault events as depicted in Microsoft Excel

You can also export the event file using right context menu from the explorer 
and follow Steps 2 and 3.

Note that selecting any export file other than the Excel (CSV) for T-PRO 
event file will result in "No data was selected, nothing eas exported" di-
alog and the export process will be terminated.
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Software Installation Instructions

The CD-ROM contains software and the User Manual for RecordBase View.

Software is installed directly from the CD-ROM to a Windows PC. 

The CD-ROM contains the following:

   •  RecordBase View interface software

   •  RecordBase View User Manual in PDF format

To Install Software 
on your Computer

Insert the CD-ROM in your drive; the CD-ROM should open automatically. If 
the it does not, go to Windows Explorer and find the CD-ROM (usually on D 
drive). Open the CD.exe file to launch the CD-ROM. 

To install the software on your computer, click the desired item on the screen. 
The installation program launches automatically. Installation may take a few 
minutes to start.

To view the User Manual you must have Adobe Acrobat on your computer. If 
you need a copy, download a copy by clicking on Download Adobe Acrobat.

For proper operation of RecordBase View ensure that the Windows 
date format is set to YYYY-MM-DD. You can set this date through 
Windows Control Panel, Regional Settings. (For Windows XP 
choose Regional and Language Options.)
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